summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-08 10:10:01 +0100
committerGuix Patches Tester <>2020-01-12 09:43:24 +0000
commit24d98e58a3a5333055287d875146be38ea412be8 (patch)
treefe53a29b2c5bb9ba30f1066aacfbfe23d4d3f8b6
parentd75a0cd98649c610c8c6ed05011233a49af156e9 (diff)
downloadpatches-series-2576.tar
patches-series-2576.tar.gz
gnu: Add python-asyncssh and dependenciesseries-2576
* gnu/packages/python-crypto.scm (python-cryptography-vectors): Version bump to 2.8 (python-cryptography): Version bump to 2.8 (python-pyopenssl)[arguments]: Disable failing tests * gnu/packages/python-xyz.scm (python-asyncssh): New variable (python-gssapi): New variable (python-k5test): New variable (python-forbiddenfruit): New variable (python-shouldbe): New variable
-rw-r--r--gnu/packages/python-crypto.scm14
-rw-r--r--gnu/packages/python-xyz.scm164
2 files changed, 173 insertions, 5 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 71172701ac..ad27971ae5 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -401,14 +401,14 @@ is used by the Requests library to verify HTTPS requests.")
(define-public python-cryptography-vectors
(package
(name "python-cryptography-vectors")
- (version "2.7")
+ (version "2.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography_vectors" version))
(sha256
(base32
- "1g38zw90510azyfrj6mxbslx2gp9yrnv5dac0w2819k9ssdznbgi"))))
+ "05pi3shqz0fgvy0d5yazza67bbnam8fkrx2ayrrclgkaqms23lvc"))))
(build-system python-build-system)
(home-page "https://github.com/pyca/cryptography")
(synopsis "Test vectors for the cryptography package")
@@ -423,14 +423,14 @@ is used by the Requests library to verify HTTPS requests.")
(define-public python-cryptography
(package
(name "python-cryptography")
- (version "2.7")
+ (version "2.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography" version))
(sha256
(base32
- "1inlnr36kl36551c9rcad99jmhk81v33by3glkadwdcgmi17fd76"))))
+ "0l8nhw14npknncxdnp7n4hpmjyscly6g7fbivyxkjwvlv071zniw"))))
(build-system python-build-system)
(inputs
`(("openssl" ,openssl)))
@@ -496,7 +496,11 @@ message digests and key derivation functions.")
"not test_fallback_default_verify_paths "
;; This test attempts to make a connection to
;; an external web service.
- "and not test_set_default_verify_paths")))))))
+ "and not test_set_default_verify_paths "
+ ;; These fail for unknown reasons.
+ "and not test_add_extra_chain_cert "
+ "and not test_use_certificate_chain_file_bytes "
+ "and not test_use_certificate_chain_file_unicode")))))))
(propagated-inputs
`(("python-cryptography" ,python-cryptography)
("python-six" ,python-six)))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2c308796e7..203e51588c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -112,6 +112,7 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages kerberos)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
@@ -17098,3 +17099,166 @@ scripts to load entry points more quickly.")
functional combinators. Parser combinators are just higher-order functions
that take parsers as their arguments and return them as result values.")
(license license:expat)))
+
+(define-public python-asyncssh
+ (package
+ (name "python-asyncssh")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asyncssh" version))
+ (sha256
+ (base32
+ "101kxyydrps9lc716vjs0nrvzfjp8644iir1xm19pl0ma73b9l0r"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-gssapi" ,python-gssapi)
+ ("python-bcrypt" ,python-bcrypt)))
+ ;; required for test suite
+ (native-inputs
+ `(("openssh" ,openssh)
+ ("openssl" ,openssl)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-tests
+ (lambda* _
+ (substitute* "tests/test_agent.py"
+ ;; Test fails for unknown reason
+ (("async def test_confirm")
+ "@unittest.skip('disabled by guix')\n "
+ "async def test_confirm")))))))
+ (home-page "https://asyncssh.readthedocs.io/")
+ (synopsis
+ "Asynchronous SSHv2 client and server library")
+ (description
+ "AsyncSSH is a Python package which provides an asynchronous client and
+server implementation of the SSHv2 protocol on top of the Python 3.6+ asyncio
+framework")
+ (license license:epl2.0)))
+
+(define-public python-gssapi
+ (package
+ (name "python-gssapi")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gssapi" version))
+ (sha256
+ (base32
+ "1gymg4asvwrz7y13qpwp2s5g8qwq179d72gkj09q6bfcgs82l5wr"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-decorator" ,python-decorator)
+ ("python-six" ,python-six)))
+ (inputs
+ `(("mit-krb5" ,mit-krb5)))
+ ;; for tests
+ (native-inputs
+ `(("python-shouldbe" ,python-shouldbe)
+ ("python-parameterized" ,python-parameterized)
+ ("python-k5test" ,python-k5test)
+ ("python-nose" ,python-nose)))
+ (home-page
+ "https://github.com/pythongssapi/python-gssapi")
+ (synopsis "Python GSSAPI Wrapper")
+ (description "Python-GSSAPI provides both low-level and high level wrappers
+around the GSSAPI C libraries. While it focuses on the Kerberos mechanism, it
+should also be useable with other GSSAPI mechanisms.")
+ (license license:isc)))
+
+(define-public python-k5test
+ (package
+ (name "python-k5test")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "k5test" version))
+ (sha256
+ (base32
+ "1lqp3jgfngyhaxjgj3n230hn90wsylwilh120yjf62h7b1s02mh8"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ;; `which`, `kadmin.local` binaries called inside library
+ ("which" ,which)
+ ("mit-krb5" ,mit-krb5)))
+ (native-inputs `(("mit-krb5" ,mit-krb5)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* _
+ (substitute* "k5test/realm.py"
+ (("'kadmin_local'") "'kadmin.local'")))))))
+ (home-page
+ "https://github.com/pythongssapi/k5test")
+ (synopsis
+ "Library for testing Python applications in self-contained Kerberos 5
+environments")
+ (description
+ "k5test is a library for setting up self-contained Kerberos 5
+environments, and running Python unit tests inside those environments.
+It is based on the file of the same name found alongside the MIT Kerberos 5
+unit tests.")
+ (license license:isc)))
+
+(define-public python-forbiddenfruit
+ (package
+ (name "python-forbiddenfruit")
+ (version "0.1.3")
+ (source
+ (origin
+ ;; Source tarball on PyPi lacks Makefile that builds and runs tests
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clarete/forbiddenfruit")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fp2xvdqpi910j9r3q68x38phpxbm700gjdi2m2j5gs91xdnyyh2"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "make" "SKIP_DEPS=1"))))))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-coverage" ,python-coverage)))
+ (home-page
+ "https://github.com/clarete/forbiddenfruit")
+ (synopsis "Patch python built-in objects")
+ (description "This project allows Python code to extend built-in types.")
+ (license (list license:gpl3+ license:expat))))
+
+(define-public python-shouldbe
+ (package
+ (name "python-shouldbe")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "shouldbe" version))
+ (sha256
+ (base32
+ "16zbvjxf71dl4yfbgcr6idyim3mdrfvix1dv8b95p0s9z07372pj"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-forbiddenfruit" ,python-forbiddenfruit)))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page
+ "https://github.com/directxman12/should_be")
+ (synopsis
+ "Python Assertion Helpers inspired by Shouldly")
+ (description
+ "Python Assertion Helpers inspired by Shouldly")
+ (license license:isc)))
+