summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Holland <josh@inv.alid.pw>2020-01-06 11:30:43 +0000
committerGuix Patches Tester <>2020-01-12 09:41:27 +0000
commit8e33aac4ddabb6c8278b1a10ad874eb1c1fb335f (patch)
tree9243f877418ed86243078ad35cd45e0a58526b9b
parentd75a0cd98649c610c8c6ed05011233a49af156e9 (diff)
downloadpatches-series-2551.tar
patches-series-2551.tar.gz
gnu: Add peg.series-2551
* gnu/packages/parser.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/parser.scm55
2 files changed, 57 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 33cf439870..7d24548754 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -26,6 +26,7 @@
# Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
# Copyright © 2019 Brett Gilio <brettg@gnu.org>
# Copyright © 2019 Amin Bandali <bandali@gnu.org>
+# Copyright © 2020 Josh Holland <josh@inv.alid.pw>
#
# This file is part of GNU Guix.
#
@@ -384,6 +385,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/ots.scm \
%D%/packages/package-management.scm \
%D%/packages/parallel.scm \
+ %D%/packages/parser.scm \
%D%/packages/password-utils.scm \
%D%/packages/patchutils.scm \
%D%/packages/pciutils.scm \
diff --git a/gnu/packages/parser.scm b/gnu/packages/parser.scm
new file mode 100644
index 0000000000..40a16915df
--- /dev/null
+++ b/gnu/packages/parser.scm
@@ -0,0 +1,55 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages parser)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+ #:use-module (guix packages))
+
+(define-public peg
+ (package
+ (name "peg")
+ (version "0.1.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.piumarta.com/software/peg/peg-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "114h1y4k8fwcq9m0hfk33dsp7ah8zxzjjzlk71x4iirzczfkn690"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (synopsis "Parser generators for Parsing Expression Grammars (PEGs)")
+ (description "peg and leg are tools for generating recursive-descent
+parsers: programs that perform pattern matching on text. They processes a
+Parsing Expression Grammar (PEG) [Ford 2004] to produce a program that
+recognises legal sentences of that grammar. peg processes PEGs written using
+the original syntax described by Ford; leg processes PEGs written using
+slightly different syntax and conventions that are intended to make it an
+attractive replacement for parsers built with lex and yacc. Unlike lex and
+yacc, peg and leg support unlimited backtracking, provide ordered choice as a
+means for disambiguation, and can combine scanning (lexical analysis) and
+parsing (syntactic analysis) into a single activity.")
+ (home-page "https://www.piumarta.com/software/peg/")
+ (license (x11-style "file://LICENSE.txt"))))