summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdouard Klein <edk@beaver-labs.com>2020-05-12 10:46:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-05-13 09:47:03 +0300
commite91c0cd88b556d272ca52c5247ac4af632e1a7cd (patch)
tree5fd4a1387f4a0e17cdbd0c73ea1c23f0b0e7b0f4
parentd93fc75e144e8e9ff7dba02c762ca5d5803d5cfb (diff)
downloadpatches-base-for-series-3938.tar
patches-base-for-series-3938.tar.gz
gnu: Add python-websockets.base-for-series-3938
* gnu/packages/python-web.scm (python-websockets): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6221c77065..88ba88e2e2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Holger Peters <holger.peters@posteo.de>
;;; Copyright © 2020 Noisytoot <noisytoot@gmail.com>
+;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3721,3 +3722,27 @@ and serve updated contents upon changes to the directory.")
(description "@code{VF-1} is a command line gopher client with
@acronym{TLS, Transport Layer Security} support.")
(license license:bsd-2)))
+
+(define-public python-websockets
+ (package
+ (name "python-websockets")
+ (version "8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "websockets" version))
+ (sha256
+ (base32
+ "03s3ml6sbki24aajllf8aily0xzrn929zxi84p50zkkbikdd4raw"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; Tests not included in release tarball.
+ (home-page "https://github.com/aaugustin/websockets")
+ (synopsis
+ "Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")
+ (description
+ "@code{websockets} is a library for building WebSocket servers and clients
+in Python with a focus on correctness and simplicity.
+
+Built on top of @code{asyncio}, Python's standard asynchronous I/O framework,
+it provides an elegant coroutine-based API.")
+ (license license:bsd-3)))