summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2020-05-09 18:33:03 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-12 15:32:06 +0200
commita1315b7fddb150977bca9a7cbe6d87e84c118753 (patch)
tree6f5b029d88e52b9760064be535e2bcb012f37747
parent5ef30f2a1f89397bc78af94b6ee95e9fce2f646e (diff)
downloadpatches-base-for-series-3932.tar
patches-base-for-series-3932.tar.gz
gnu: Add julia-compat.base-for-series-3932
* gnu/packages/julia-xyz.scm: New file. * gnu/local.mk: Add packages/julia-xyz.scm to it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/julia-xyz.scm45
2 files changed, 46 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7d023c649b..02542cc820 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -291,6 +291,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/jrnl.scm \
%D%/packages/jose.scm \
%D%/packages/julia.scm \
+ %D%/packages/julia-xyz.scm \
%D%/packages/jupyter.scm \
%D%/packages/kawa.scm \
%D%/packages/kde.scm \
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
new file mode 100644
index 0000000000..f1da66a4be
--- /dev/null
+++ b/gnu/packages/julia-xyz.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages julia-xyz)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system julia))
+
+(define-public julia-compat
+ (package
+ (name "julia-compat")
+ (version "3.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaLang/Compat.jl")
+ (commit (string-append "v" version))))
+ (file-name "Compat")
+ (sha256
+ (base32 "01vwjr2134bzgnaxwd67knbibbhnfgnqjw7gxrp29s6y2a6j3882"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaLang/Compat.jl")
+ (synopsis "Compatibility across Julia versions")
+ (description "The Compat package is designed to ease interoperability
+between older and newer versions of the Julia language. The Compat package
+provides a macro that lets you use the latest syntax in a backwards-compatible
+way.")
+ (license license:expat)))