summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-01-12 18:42:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-14 17:49:26 +0100
commit64fc4f3705423c83c680a95d8dea81a39fce9a70 (patch)
treec20f833167f07f3b20335af81d0dacc335c04be6
parent7af0f2156c1576773a693f9d61d2fab308b390d3 (diff)
downloadpatches-base-for-series-2903.tar
patches-base-for-series-2903.tar.gz
gnu: Add gst-editing-services.base-for-series-2903
* gnu/packages/gstreamer.scm (gst-editing-services): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/gstreamer.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 1e26a3ce3e..0709d8568b 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -476,6 +477,39 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
compression formats through the use of the libav library.")
(license license:gpl2+)))
+(define-public gst-editing-services
+ (package
+ (name "gst-editing-services")
+ (version "1.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gstreamer.freedesktop.org/src/" name "/"
+ "gstreamer-editing-services-" version ".tar.xz"))
+ (sha256
+ (base32
+ "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
+ (build-system meson-build-system)
+ (arguments
+ ;; FIXME: 16/22 failing tests.
+ `(#:tests? #f))
+ (inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("libxml2" ,libxml2)))
+ (native-inputs
+ `(("flex" ,flex)
+ ("gst-plugins-bad" ,gst-plugins-bad)
+ ("gst-plugins-good" ,gst-plugins-good)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page "https://gstreamer.freedesktop.org/")
+ (synopsis "GStreamer library for non-linear editors")
+ (description
+ "This is a high-level library for facilitating the creation of audio/video
+non-linear editors.")
+ (license license:gpl2+)))
+
(define-public python-gst
(package
(name "python-gst")