aboutsummaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
Diffstat (limited to 'guix')
-rw-r--r--guix/config.scm.in20
1 files changed, 17 insertions, 3 deletions
diff --git a/guix/config.scm.in b/guix/config.scm.in
index 223c9eb418..d582d91d74 100644
--- a/guix/config.scm.in
+++ b/guix/config.scm.in
@@ -61,9 +61,23 @@
(define %channel-metadata
;; When true, this is an sexp containing metadata for the 'guix' channel
;; this file was built from. This is used by (guix describe).
-
- ;; TODO: Implement 'configure.ac' machinery to initialize it.
- #f)
+ (let ((url @GUIX_CHANNEL_URL@)
+ (commit @GUIX_CHANNEL_COMMIT@)
+ (intro @GUIX_CHANNEL_INTRODUCTION@))
+ (and url commit
+ `(repository
+ (version 0)
+ (url ,url)
+ (branch "master") ;XXX: doesn't really matter
+ (commit ,commit)
+ (name guix)
+ ,@(if intro
+ `((introduction
+ (channel-introduction
+ (version 0)
+ (commit ,(car intro))
+ (signer ,(cdr intro)))))
+ '())))))
(define %storedir
"@storedir@")