aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-crypto.scm32
-rw-r--r--gnu/packages/golang.scm30
2 files changed, 32 insertions, 30 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 3fbeac703b..e89c486bcc 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2021 BonfaceKilz <me@bonfacemunyoki.com>
;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
@@ -1068,6 +1069,37 @@ Architecture Processors\" by J. Guilford et al.")
(description "Multihash implementation in Go.")
(license license:expat)))
+(define-public go-github-com-oneofone-xxhash
+ (package
+ (name "go-github-com-oneofone-xxhash")
+ (version "1.2.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OneOfOne/xxhash")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0f98qk83l2fhpclvrgyxsa9b8m4pipf11fah85bnjl01wy4lvybw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/OneOfOne/xxhash"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-benchmarks
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/benchmarks")))))))
+ (home-page "https://github.com/OneOfOne/xxhash")
+ (synopsis "Go implementation of xxHash")
+ (description
+ "This is a native Go implementation of the
+@url{https://github.com/Cyan4973/xxHash, xxHash} algorithm, an extremely fast
+non-cryptographic hash algorithm, working at speeds close to RAM limits.")
+ (license license:asl2.0)))
+
(define-public go-github-com-operatorfoundation-ed25519
(let ((commit "b22b4bd3ddef042eec45f3ee135cd40281fde2b4")
(revision "0"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3c19f5abb1..2c5f496b2e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8013,36 +8013,6 @@ friendly sizes. It converts boring ugly numbers to human-friendly strings and
back.")
(license license:expat)))
-(define-public go-github-com-oneofone-xxhash
- (package
- (name "go-github-com-oneofone-xxhash")
- (version "1.2.8")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/OneOfOne/xxhash")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0f98qk83l2fhpclvrgyxsa9b8m4pipf11fah85bnjl01wy4lvybw"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/OneOfOne/xxhash"
- #:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'remove-benchmarks
- (lambda* (#:key import-path #:allow-other-keys)
- (delete-file-recursively
- (string-append "src/" import-path "/benchmarks")))))))
- (home-page "https://github.com/OneOfOne/xxhash")
- (synopsis "Go implementation of xxHash")
- (description "This is a native Go implementation of the
-@url{https://github.com/Cyan4973/xxHash, xxHash} algorithm, an extremely fast
-non-cryptographic hash algorithm, working at speeds close to RAM limits.")
- (license license:asl2.0)))
-
(define-public go-gopkg-in-djherbis-times-v1
(package
(name "go-gopkg-in-djherbis-times-v1")