aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1a41af9d0d..160921c78a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5677,3 +5677,29 @@ percentage, bars of various formats, elapsed time and estimated time remaining.
(home-page
"https://github.com/rest-client/rest-client")
(license license:expat)))
+
+(define-public ruby-hashdiff
+ (package
+ (name "ruby-hashdiff")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "hashdiff" version))
+ (sha256
+ (base32
+ "1r06gar8zp4hyzyc0ky7n6mybjj542lrfda5y78fm5hyhiplv104"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f
+ #:test-target "spec"))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec-2)))
+ (synopsis
+ " HashDiff is a diff lib to compute the smallest difference between two hashes. ")
+ (description
+ " HashDiff is a diff lib to compute the smallest difference between two hashes. ")
+ (home-page
+ "https://github.com/liufengyun/hashdiff")
+ (license license:expat)))