aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c28b0675ad..f146746058 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19000,6 +19000,15 @@ from the header, as well as section details and data available.")
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
+ ,@(if (target-riscv64?)
+ ;; TODO: Remove the conditional on staging.
+ `((add-after 'unpack 'remove-test-hypothesis-deadlines
+ (lambda _
+ (substitute* "tests/test_make.py"
+ (("assume, given") "assume, given, settings")
+ (("( +)@given" all spaces)
+ (string-append spaces "@settings(deadline=None)\n" all))))))
+ '())
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?