aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mastodon.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index f23ff062fa..4847bbeed9 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -52,9 +52,10 @@
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "py.test"))))))
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "py.test")))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(inputs