aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 35c40f233c..1584943ac2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5218,6 +5218,16 @@ libxml2.")
'(#:configure-flags
`("--without-plymouth"
"--disable-systemd-journal"
+
+ ;; Using --with-initial-vt=7 allows GDM to run alongside TTY 1,
+ ;; instead of having to replace it (i.e., stopping the mingetty
+ ;; service for TTY 1 before starting GDM).
+ "--with-initial-vt=7"
+
+ ;; By default, GDM expects distributions to install a custom Xsession
+ ;; script. It provides a generic one if --enable-gdm-xsession is set.
+ "--enable-gdm-xsession"
+
"--localstatedir=/var"
,(string-append "--with-default-path="
(string-join '("/run/setuid-programs"