aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 986069364c..38f86c4d33 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -8229,6 +8229,37 @@ in Perl but is not nearly as capable as @code{HTML::Tidy}.")
@end itemize")
(license license:bsd-2))))
+(define-public gemget
+ (package
+ (name "gemget")
+ (version "1.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/makew0rld/gemget")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03x9apk73lwyafc4fd2vs033z7vcpk4k0jf97452l7pnlx2v57rz"))))
+ (build-system go-build-system)
+ (native-inputs
+ (list go-github-com-dustin-go-humanize
+ go-github-com-makeworld-the-better-one-go-gemini
+ go-github-com-makeworld-the-better-one-go-gemini-socks5
+ go-github-com-schollz-progressbar-v3
+ go-github-com-spf13-pflag))
+ (arguments
+ (list
+ #:install-source? #f
+ #:import-path "github.com/makeworld-the-better-one/gemget"))
+ (home-page "https://github.com/makew0rld/gemget")
+ (synopsis "Command line downloader for the Gemini protocol")
+ (description
+ "Gemget is a command line downloader for the Gemini protocol.
+It works well with streams and can print headers for debugging as well.")
+ (license license:expat)))
+
(define-public geomyidae
(package
(name "geomyidae")