aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm4
-rw-r--r--gnu/packages/check.scm30
-rw-r--r--gnu/packages/python-check.scm2
3 files changed, 3 insertions, 33 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index eb49952230..97b7a73b9c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1629,7 +1629,7 @@ Main features:
python-psutil
;; 3.3.0+ requries newer version of pytest, see
;; <https://github.com/asdf-format/asdf/issues/1804>.
- python-pytest-8
+ python-pytest
python-pytest-doctestplus
python-pytest-remotedata
python-pytest-xdist
@@ -2673,7 +2673,7 @@ sensitivity or energy density
(list nss-certs-for-test
pkg-config
python-cython-3
- python-pytest-8
+ python-pytest
python-pytest-astropy-header
python-pytest-cython
;python-pytest-doctestplus
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index a5264a9e46..f1adfbb558 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1589,36 +1589,6 @@ and functions, detailed info on failing assert statements, modular fixtures,
and many external plugins.")
(license license:expat)))
-(define-public python-pytest-8
- (package/inherit python-pytest
- (name "python-pytest")
- (version "8.2.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest" version))
- (sha256
- (base32 "0xvr25qvmdh6z03jpgg24adhgqkvkal2g2v8vk63j6909q8bhjyy"))))
- (build-system pyproject-build-system)
- (arguments
- (list
- #:test-flags
- #~(list "-k" (string-append
- "not test_code_highlight_continuation"
- " and not test_code_highlight"
- " and not test_code_highlight_custom_theme"
- " and not test_code_highlight_invalid_theme"
- " and not test_code_highlight_invalid_theme_mode"
- " and not test_code_highlight_simple"
- " and not test_color_yes"
- " and not test_comparisons_handle_colors"
- " and not test_empty_NO_COLOR_and_FORCE_COLOR_ignored"
- " and not test_remove_dir_prefix"))))
- (propagated-inputs
- (modify-inputs (package-propagated-inputs python-pytest)
- (append python-exceptiongroup)
- (replace "python-pluggy" python-pluggy-next)))))
-
(define-public python-pytest-next
(package/inherit python-pytest
(name "python-pytest")
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index e643806371..6b558c6698 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1967,7 +1967,7 @@ plain (undecoratored) native coroutine tests.")
python-cython-3
python-setuptools))
(propagated-inputs
- (list python-pytest-8))
+ (list python-pytest))
(home-page "https://github.com/lgpage/pytest-cython")
(synopsis "Cython extension modules testing plugin")
(description