aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/maths.scm6
-rw-r--r--gnu/packages/patches/dune-grid-add-missing-include-cassert.patch24
3 files changed, 2 insertions, 29 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7da7cc3735..f51abd8fe3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1165,7 +1165,6 @@ dist_patch_DATA = \
%D%/packages/patches/dtc-meson-cell-overflow.patch \
%D%/packages/patches/duc-fix-test-sh.patch \
%D%/packages/patches/dune-common-skip-failing-tests.patch \
- %D%/packages/patches/dune-grid-add-missing-include-cassert.patch \
%D%/packages/patches/dune-istl-fix-solver-playground.patch \
%D%/packages/patches/durden-shadow-arcan.patch \
%D%/packages/patches/dvd+rw-tools-add-include.patch \
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c3e4efb471..5c3ffd6d2d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8500,7 +8500,7 @@ This package contains the DUNE UG grid classes.")
(define-public dune-grid
(package
(name "dune-grid")
- (version "2.9.0")
+ (version "2.10.0")
(source
(origin
(method url-fetch)
@@ -8508,9 +8508,7 @@ This package contains the DUNE UG grid classes.")
version "/dune-grid-" version ".tar.gz"))
(sha256
(base32
- "17l2vlr8q3rfifxv80r3jlzamx478xn0vfjkrl3ns1akk7miycq8"))
- (patches (search-patches
- "dune-grid-add-missing-include-cassert.patch"))))
+ "0mh06g3sryx3s0d7zgzsz6j18vbzb0f46wq7aw6ahj2hswb7rsrg"))))
(build-system cmake-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/patches/dune-grid-add-missing-include-cassert.patch b/gnu/packages/patches/dune-grid-add-missing-include-cassert.patch
deleted file mode 100644
index 7462b11934..0000000000
--- a/gnu/packages/patches/dune-grid-add-missing-include-cassert.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From ef843b1a66308247ba4d2e2c116ff5517421a91b Mon Sep 17 00:00:00 2001
-From: Simon Praetorius <simon.praetorius@tu-dresden.de>
-Date: Tue, 6 Dec 2022 13:39:44 +0100
-Subject: [PATCH] Add missing include <cassert>
-
----
- dune/grid/test/yasp/test-yaspgrid-partitioner.cc | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/dune/grid/test/yasp/test-yaspgrid-partitioner.cc b/dune/grid/test/yasp/test-yaspgrid-partitioner.cc
-index 93ae042b0..9a4530201 100644
---- a/dune/grid/test/yasp/test-yaspgrid-partitioner.cc
-+++ b/dune/grid/test/yasp/test-yaspgrid-partitioner.cc
-@@ -6,6 +6,7 @@
- #include <config.h>
-
- #include <array>
-+#include <cassert>
- #include <iostream>
-
- #include <dune/common/filledarray.hh>
---
-2.39.2
-