aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-check.scm4
-rw-r--r--gnu/packages/haskell-web.scm2
-rw-r--r--gnu/packages/haskell-xyz.scm30
3 files changed, 18 insertions, 18 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index c2cffbad9e..e50c7d7eea 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -489,7 +489,7 @@ use HUnit assertions as QuickCheck properties.")
(package
(name "ghc-quickcheck")
(version "2.13.2")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -651,7 +651,7 @@ using Template Haskell")
(package
(name "ghc-hunit")
(version "1.6.0.0")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index c53dc064b1..82da50f456 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -171,7 +171,7 @@ both client and server code).")
(package
(name "ghc-http")
(version "4000.3.14")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 77288784d8..d62560cb00 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -1519,7 +1519,7 @@ call stacks with different versions of the compiler.")
(package
(name "ghc-case-insensitive")
(version "1.2.0.11")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -4090,7 +4090,7 @@ consuming feeds in both RSS (Really Simple Syndication) and Atom format.")
(package
(name "ghc-fgl")
(version "5.7.0.1")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -5206,7 +5206,7 @@ Happy works in a similar way to the yacc tool for C.")
(package
(name "ghc-hashable")
(version "1.2.7.0")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -8127,7 +8127,7 @@ ncurses.")
(package
(name "ghc-network")
(version "2.8.0.1")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -8221,7 +8221,7 @@ IPv4, IPv6 and MAC addresses.")
(package
(name "ghc-network-uri")
(version "2.6.1.0")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -8903,7 +8903,7 @@ building up, manipulating and serialising @code{Pandoc} structures.")
(package
(name "ghc-parallel")
(version "3.2.2.0")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -9069,7 +9069,7 @@ files/directories, and more.")
(package
(name "ghc-paths")
(version "0.1.0.12")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -9673,7 +9673,7 @@ Show instance.")
(package
(name "ghc-primitive")
(version "0.6.4.0")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -9942,7 +9942,7 @@ usable.")
(package
(name "ghc-random")
(version "1.1")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -11610,7 +11610,7 @@ used for example by QuickCheck, see quickcheck-special." )
(package
(name "ghc-split")
(version "0.2.3.3")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -12145,7 +12145,7 @@ building Scalable Vector Graphics (SVG).")
(package
(name "ghc-syb")
(version "0.7.1")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -12590,7 +12590,7 @@ string metrics efficiently.")
(package
(name "ghc-tf-random")
(version "0.5")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -13579,7 +13579,7 @@ functions.")
(package
(name "ghc-unordered-containers")
(version "0.2.10.0")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -13934,7 +13934,7 @@ representing a store for a single element.")
(package
(name "ghc-vector")
(version "0.12.0.3")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)
@@ -14521,7 +14521,7 @@ modifying, and extracting files from zip archives in Haskell.")
(package
(name "ghc-zlib")
(version "0.6.2.1")
- (outputs '("out" "doc"))
+ (outputs '("out" "static" "doc"))
(source
(origin
(method url-fetch)