aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crypto.scm6
-rw-r--r--gnu/packages/image.scm79
-rw-r--r--gnu/packages/scrot.scm68
3 files changed, 150 insertions, 3 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index e78afb62d6..5fbc0cf857 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -26,7 +26,7 @@
(define-public libsodium
(package
(name "libsodium")
- (version "0.5.0")
+ (version "1.0.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -34,11 +34,11 @@
version ".tar.gz"))
(sha256
(base32
- "1w7rrnsvhhzhywrr3nhlhppv4kqzdszz3dwy8jrsv8lrj5hs181w"))))
+ "19f9vf0shfp4rc4l791r6xjg06z4i8psj1zkjkm3z5b640yzxlff"))))
(build-system gnu-build-system)
(synopsis "Portable NaCl-based crypto library")
(description
"libsodium is a new easy-to-use high-speed software library for network
communication, encryption, decryption, signatures, etc.")
(license isc)
- (home-page "https://github.com/jedisct1/libsodium"))) ; No real homepage
+ (home-page "http://libsodium.org")))
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 981d3a8976..0e79942f19 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -23,6 +23,8 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xml)
#:use-module (gnu packages ghostscript) ;lcms
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages giflib)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -213,3 +215,80 @@ an indexing tool useful for the JPIP protocol, JPWL-tools for
error-resilience, a Java-viewer for j2k-images, ...")
(home-page "http://jbig2dec.sourceforge.net/")
(license license:bsd-2)))
+
+(define-public imlib2
+ (package
+ (name "imlib2")
+ (version "1.4.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/enlightenment/imlib2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0kjggg4gfn6chi8v1xddd5qwk1fbnl7rvd93qiclv5v11s615k0p"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(;; Will be fixed in the next release:
+ ;; <http://git.enlightenment.org/legacy/imlib2.git/commit/?id=5dde234b2d3caf067ea827858c53adc5d4c56c13>.
+ #:phases (alist-cons-before
+ 'configure 'patch-config
+ (lambda _
+ (substitute* "imlib2-config.in"
+ (("@my_libs@") "")))
+ %standard-phases)))
+ (native-inputs
+ `(("pkgconfig" ,pkg-config)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("freetype" ,freetype)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("giflib" ,giflib)
+ ("bzip2" ,bzip2)))
+ (home-page "http://sourceforge.net/projects/enlightenment/")
+ (synopsis
+ "Loading, saving, rendering and manipulating image files")
+ (description
+ "Imlib2 is a library that does image file loading and saving as well as
+rendering, manipulation, arbitrary polygon support, etc.
+
+It does ALL of these operations FAST. Imlib2 also tries to be highly
+intelligent about doing them, so writing naive programs can be done easily,
+without sacrificing speed.
+
+This is a complete rewrite over the Imlib 1.x series. The architecture is
+more modular, simple, and flexible.")
+ ;; This license adds several sentences to the original X11 license.
+ (license (license:x11-style "file://COPYING"
+ "See 'COPYING' in the distribution."))))
+
+(define-public giblib
+ (package
+ (name "giblib")
+ (version "1.2.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://linuxbrit.co.uk/downloads/giblib-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1b4bmbmj52glq0s898lppkpzxlprq9aav49r06j2wx4dv3212rhp"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libx11" ,libx11)
+ ("imlib2" ,imlib2)))
+ (home-page "http://linuxbrit.co.uk/software/") ; no real home-page
+ (synopsis "Wrapper library for imlib2")
+ (description
+ "giblib is a simple library which wraps imlib2's context API, avoiding
+all the context_get/set calls, adds fontstyles to the truetype renderer and
+supplies a generic doubly-linked list and some string functions.")
+ ;; This license removes a clause about X Consortium from the original
+ ;; X11 license.
+ (license (license:x11-style "file://COPYING"
+ "See 'COPYING' in the distribution."))))
diff --git a/gnu/packages/scrot.scm b/gnu/packages/scrot.scm
new file mode 100644
index 0000000000..a5bbe187bd
--- /dev/null
+++ b/gnu/packages/scrot.scm
@@ -0,0 +1,68 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages scrot)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages image))
+
+(define-public scrot
+ (package
+ (name "scrot")
+ (version "0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://linuxbrit.co.uk/downloads/scrot-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1wll744rhb49lvr2zs6m93rdmiq59zm344jzqvijrdn24ksiqgb1"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; By default, man and doc are put in PREFIX/{man,doc} instead of
+ ;; PREFIX/share/{man,doc}.
+ '(#:configure-flags
+ (list (string-append "--mandir="
+ (assoc-ref %outputs "out")
+ "/share/man"))
+ #:phases (alist-replace
+ 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/scrot")))
+ (mkdir-p doc)
+ (zero?
+ (system* "make" "install"
+ (string-append "docsdir=" doc)))))
+ %standard-phases)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("giblib" ,giblib)))
+ (home-page "http://linuxbrit.co.uk/software/")
+ (synopsis "Command-line screen capture utility for X Window System")
+ (description
+ "scrot allows to save a screenshot of a full screen, a window or a part
+of the screen selected by mouse.")
+ ;; This license removes a clause about X Consortium from the original
+ ;; X11 license.
+ (license (x11-style "file://COPYING"
+ "See 'COPYING' in the distribution."))))