aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 853a259c85..2a9a31e3e2 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1953,6 +1953,20 @@ encoder/decoder, round-off-error-free sum and cumsum, etc.")
"0c7gs9c8xdjfxviw0syh13pf3vys2b2ssixmnyqbji64xdscn7pz"))))
(properties `((upstream-name . "rmarkdown")))
(build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; See https://github.com/rstudio/rmarkdown/pull/800
+ ;; The resource files are in the store and have mode 444. After
+ ;; copying the files R fails to remove them again because it doesn't
+ ;; have write access to them.
+ (add-after 'unpack 'copy-files-without-mode
+ (lambda _
+ (substitute* "R/render.R"
+ (("file.copy\\(from = from," prefix)
+ (string-append prefix
+ " copy.mode = FALSE, ")))
+ #t)))))
(propagated-inputs
`(("r-catools" ,r-catools)
("r-htmltools" ,r-htmltools)