aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gl.scm1
-rw-r--r--gnu/packages/video.scm6
-rw-r--r--gnu/packages/xorg.scm6
3 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 8494b48603..920cc92655 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -251,7 +251,6 @@ also known as DXTn or DXTC) for Mesa.")
("xorgproto" ,xorgproto)))
(inputs
`(("expat" ,expat)
- ("dri2proto" ,dri2proto)
("dri3proto" ,dri3proto)
("libelf" ,libelf) ;required for r600 when using llvm
("libva" ,(force libva-without-mesa))
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ffc5f33e7b..15e1e2caeb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1936,9 +1936,9 @@ and JACK.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("dri2proto" ,dri2proto)
- ("libx11" ,libx11 "out")
- ("libxext" ,libxext)))
+ `(("libx11" ,libx11 "out")
+ ("libxext" ,libxext)
+ ("xorgproto" ,xorgproto)))
(home-page "https://wiki.freedesktop.org/www/Software/VDPAU/")
(synopsis "Video Decode and Presentation API")
(description "VDPAU is the Video Decode and Presentation API for UNIX. It
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d895f56387..4df95a1fb4 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -346,7 +346,8 @@ servers making up a large display.")
"Direct Rendering Infrastructure 2 Extension defines a protocol to
securely allow user applications to access the video hardware without
requiring data to be passed through the X server.")
- (license license:x11)))
+ (license license:x11)
+ (properties `((superseded . ,xorgproto)))))
(define-public dri3proto
(package
@@ -5094,8 +5095,7 @@ over Xlib, including:
(file-name "xorg-server-use-intel-only-on-pre-gen4.diff"))))))
(build-system gnu-build-system)
(propagated-inputs
- `(("dri2proto" ,dri2proto)
- ("dri3proto" ,dri3proto)
+ `(("dri3proto" ,dri3proto)
("libpciaccess" ,libpciaccess)
("mesa" ,mesa)
("pixman" ,pixman)