aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 82b9fa59d5..f131499766 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -872,9 +872,9 @@ interface around the standard library's @code{time} package so that the applicat
can use the realtime clock while tests can use the mock clock.")
(license license:expat)))
-(define-public go-github-com-beorn7-perks-quantile
+(define-public go-github-com-beorn7-perks
(package
- (name "go-github-com-beorn7-perks-quantile")
+ (name "go-github-com-beorn7-perks")
(version "1.0.1")
(source
(origin
@@ -887,8 +887,17 @@ can use the realtime clock while tests can use the mock clock.")
(base32 "17n4yygjxa6p499dj3yaqzfww2g7528165cl13haj97hlx94dgl7"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/beorn7/perks/quantile"
- #:unpack-path "github.com/beorn7/perks"))
+ (list
+ #:import-path "github.com/beorn7/perks"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Workaround for go-build-system's lack of Go modules support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(home-page "https://github.com/beorn7/perks")
(synopsis "Compute approximate quantiles over an unbounded data stream")
(description