aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/dico.scm5
-rw-r--r--gnu/packages/patches/dico-idxgcide-bug.patch21
2 files changed, 24 insertions, 2 deletions
diff --git a/gnu/packages/dico.scm b/gnu/packages/dico.scm
index 780d8efcc7..87062f94dc 100644
--- a/gnu/packages/dico.scm
+++ b/gnu/packages/dico.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,7 +44,8 @@
(base32
"04pjks075x20d19l623mj50bw64g8i41s63z4kzzqcbg9qg96x64"))
(patches (search-patches "cpio-gets-undeclared.patch"
- "dico-libtool-deterministic.patch"))))
+ "dico-libtool-deterministic.patch"
+ "dico-idxgcide-bug.patch"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
diff --git a/gnu/packages/patches/dico-idxgcide-bug.patch b/gnu/packages/patches/dico-idxgcide-bug.patch
new file mode 100644
index 0000000000..28cc8a6a08
--- /dev/null
+++ b/gnu/packages/patches/dico-idxgcide-bug.patch
@@ -0,0 +1,21 @@
+Reported at <http://mail.gnu.org.ua/archives/bug-dico/2016-07/msg00000.html>.
+Patch the .c file to avoid depending on Flex.
+
+commit 4599abbda3b5979367138ea098e435c919fe93fc
+Author: Sergey Poznyakoff <gray@gnu.org>
+Date: Thu Jul 28 14:09:58 2016 +0300
+
+ Bugfix
+
+ * modules/gcide/idxgcide.l (main): Initialize ipg_header.
+
+--- dico-2.2/modules/gcide/idxgcide.c 2016-07-28 14:15:07.823587004 +0200
++++ dico-2.2/modules/gcide/idxgcide.c 2016-07-28 14:15:09.435600549 +0200
+@@ -2497,6 +2497,7 @@ main(int argc, char **argv)
+ dico_log(L_ERR, 0, _("not enough memory"));
+ exit(EX_UNAVAILABLE);
+ }
++ idx_page->ipg_header.hdr.phdr_numentries = 0;
+ idx_page->ipg_header.hdr.phdr_text_offset = idx_header.ihdr_pagesize / 2;
+
+ idx_header.ihdr_maxpageref = idx_header.ihdr_pagesize / 2 /