aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnupg.scm11
-rw-r--r--gnu/packages/patches/pius.patch38
2 files changed, 5 insertions, 44 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 7a7ff966bb..c5c99bfeb6 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -628,7 +628,7 @@ signing, decryption, verification, and key-listing parsing.")
(define-public pius
(package
(name "pius")
- (version "2.2.6")
+ (version "2.2.7")
(source (origin
(method url-fetch)
(uri (string-append
@@ -636,15 +636,14 @@ signing, decryption, verification, and key-listing parsing.")
version "/pius-" version ".tar.bz2"))
(sha256
(base32
- "1893hzpx3zv724drqv48csrn0cm98xw4ymb1zmhs2jvjj1778zfj"))
- (patches (search-patches "pius.patch"))))
+ "1nsl7czicv95j0gfz4s82ys3g3h2mwr6cq3ilid8bpz3iy7z4ipy"))))
(build-system python-build-system)
- (inputs `(("perl" ,perl) ;for 'pius-party-worksheet'
+ (inputs `(("perl" ,perl) ; for 'pius-party-worksheet'
("gpg" ,gnupg)
("python-six" ,python2-six)))
(arguments
`(#:tests? #f
- #:python ,python-2 ;uses the Python 2 'print' syntax
+ #:python ,python-2 ; uses the Python 2 'print' syntax
#:phases
(modify-phases %standard-phases
(add-before
diff --git a/gnu/packages/patches/pius.patch b/gnu/packages/patches/pius.patch
deleted file mode 100644
index da39731d4d..0000000000
--- a/gnu/packages/patches/pius.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-See https://github.com/jaymzh/pius/pull/96
-
-commit 4dba0bf75ab351969622f7b9c38484657411a528
-Author: Martin Kletzander <nert.pinx+github@gmail.com>
-Date: Thu May 17 17:55:27 2018 +0200
-
- Don't fail on ENCRYPTION_COMPLIANCE_MODE line from too new GnuPG (#96)
-
- GnuPG started printing information about encryption compliance in [commit
- f31dc2540acf](https://dev.gnupg.org/rGf31dc2540acf7cd7f09fd94658e815822222bfcb)
- and since then signing with pius fails.
-
- Closes #95
-
- Signed-off-by: Martin Kletzander <nert.pinx@gmail.com>
-
-diff --git a/libpius/signer.py b/libpius/signer.py
-index 3c7262f..13013bb 100644
---- a/libpius/signer.py
-+++ b/libpius/signer.py
-@@ -45,6 +45,7 @@ class PiusSigner(object):
- GPG_PINENTRY_LAUNCHED = '[GNUPG:] PINENTRY_LAUNCHED'
- GPG_KEY_CONSIDERED = '[GNUPG:] KEY_CONSIDERED'
- GPG_WARN_VERSION = '[GNUPG:] WARNING server_version_mismatch'
-+ GPG_ENC_COMPLIANT_MODE = '[GNUPG:] ENCRYPTION_COMPLIANCE_MODE'
-
- def __init__(self, signer, force_signer, mode, keyring, gpg_path, tmpdir,
- outdir, encrypt_outfiles, mail, mailer, verbose, sort_keyring,
-@@ -431,6 +432,9 @@ class PiusSigner(object):
- if PiusSigner.GPG_ENC_BEG in line:
- debug('Got GPG_ENC_BEG')
- continue
-+ elif PiusSigner.GPG_ENC_COMPLIANT_MODE in line:
-+ debug('Got ENCRYPTION_COMPLIANCE_MODE')
-+ continue
- elif PiusSigner.GPG_ENC_END in line:
- debug('Got GPG_ENC_END')
- break