aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/algebra.scm43
-rw-r--r--gnu/packages/backup.scm4
-rw-r--r--gnu/packages/cdrom.scm2
-rw-r--r--gnu/packages/emacs.scm2
-rw-r--r--gnu/packages/guile.scm20
-rw-r--r--gnu/packages/image.scm69
-rw-r--r--gnu/packages/libcanberra.scm36
-rw-r--r--gnu/packages/linux.scm4
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/ocaml.scm67
-rw-r--r--gnu/packages/ots.scm4
-rw-r--r--gnu/packages/patches/jbig2dec-ignore-testtest.patch14
-rw-r--r--gnu/packages/patches/mupdf-buildsystem-fix.patch69
-rw-r--r--gnu/packages/patches/valgrind-glibc.patch21
-rw-r--r--gnu/packages/pdf.scm67
-rw-r--r--gnu/packages/pulseaudio.scm9
-rw-r--r--gnu/packages/skribilo.scm16
-rw-r--r--gnu/packages/tcl.scm9
-rw-r--r--gnu/packages/valgrind.scm7
19 files changed, 413 insertions, 52 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 7fc31abae7..53382eb67b 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -205,6 +205,49 @@ fast arithmetic.")
(license gpl2+)
(home-page "http://flintlib.org/")))
+(define-public arb
+ (package
+ (name "arb")
+ (version "2.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/fredrik-johansson/arb/archive/"
+ version ".tar.gz"))
+ (sha256 (base32
+ "0a8cgzznkmr59ngj4di9a37b5h4i00gbnixnxlwd34bcbflvjzyr"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("flint" ,flint)
+ ("gmp" ,gmp)
+ ("mpfr" ,mpfr)))
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (flint (assoc-ref inputs "flint"))
+ (gmp (assoc-ref inputs "gmp"))
+ (mpfr (assoc-ref inputs "mpfr")))
+ ;; do not pass "--enable-fast-install", which makes the
+ ;; homebrew configure process fail
+ (zero? (system*
+ "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--with-flint=" flint)
+ (string-append "--with-gmp=" gmp)
+ (string-append "--with-mpfr=" mpfr)))))
+ %standard-phases)))
+ (synopsis "Arbitrary precision floating-point ball arithmetic")
+ (description
+ "Arb is a C library for arbitrary-precision floating-point ball
+arithmetic. It supports efficient high-precision computation with
+polynomials, power series, matrices and special functions over the
+real and complex numbers, with automatic, rigorous error control.")
+ (license gpl2+)
+ (home-page "http://fredrikj.net/arb/")))
+
(define-public bc
(package
(name "bc")
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 5c44786af3..d6e106071f 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -34,6 +34,7 @@
#:use-module (gnu packages nettle)
#:use-module (gnu packages pcre)
#:use-module (gnu packages python)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages rsync)
#:use-module (gnu packages ssh)
@@ -56,7 +57,8 @@
"0l14nrhbgkyjgvh339bbhnm6hrdwrjadphq1jmpi0mcgcdbdfh8x"))))
(build-system python-build-system)
(native-inputs
- `(("python2-setuptools" ,python2-setuptools)))
+ `(("python2-setuptools" ,python2-setuptools)
+ ("util-linux" ,util-linux))) ;setsid command, for the tests
(inputs
`(("python" ,python-2)
("librsync" ,librsync)
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 518cfc3c2b..7c62e59626 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -163,7 +163,7 @@ files.")
(synopsis "audio CD reading utility which includes extra data verification features")
(description "Cdparanoia retrieves audio tracks from CDDA capable CDROM
drives. The data can be saved to a file or directed to standard output
-in WAV, AIFF, AIFF-C or raw format. Most ATAPI, SCSI and several
+in WAV, AIFF, AIFF-C or raw format. Most ATAPI, SCSI and several
proprietary CDROM drive makes are supported; cdparanoia can determine if the
target drive is CDDA capable. In addition to simple reading, cdparanoia adds
extra-robust data verification, synchronization, error handling and scratch
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1a37bef657..a788bd8fde 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -79,7 +79,7 @@
;; TODO: Add the optional dependencies.
("xlibs" ,libx11)
- ("gtk+" ,gtk+-2)
+ ("gtk+" ,gtk+)
("libXft" ,libxft)
("libtiff" ,libtiff)
("giflib" ,giflib)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 1169158113..e928c311e4 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -359,27 +359,25 @@ http:://json.org specification. These are the main features:
(define-public guile-charting
(package
(name "guile-charting")
- (version "0.1.1")
+ (version "0.2.0")
(source (origin
(method url-fetch)
(uri (string-append "http://wingolog.org/pub/guile-charting/"
"guile-charting-" version ".tar.gz"))
(sha256
(base32
- "1l8xcqq4cp67jzxnmf07ivsgq23mfmi00zz1s8bnv2zkb0ab9475"))
+ "0w5qiyv9v0ip5li22x762bm48g8xnw281w66iyw094zdw611pb2m"))
(modules '((guix build utils)))
(snippet
- ;; Remove dependency from guile-charting.texi to
- ;; guile-chartingscmfiles to avoid rebuild the doc (which is
- ;; unnecessary and fails with "failed to match any pattern in
- ;; form define-macro-with-docs" as of Guile 2.0.11.)
- '(substitute* "doc/Makefile.in"
- (("^(.+):(.*) \\$\\(doc\\)scmfiles(.*$)" _ target dep1 dep2)
- (string-append target ":" dep1 " " dep2 "\n"))))))
+ '(begin
+ ;; Use the standard location for modules.
+ (substitute* "Makefile.in"
+ (("godir = .*$")
+ "godir = $(moddir)\n"))))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("guile" ,guile-2.0)
- ("guile-cairo" ,guile-cairo)))
+ (inputs `(("guile" ,guile-2.0)))
+ (propagated-inputs `(("guile-cairo" ,guile-cairo)))
(home-page "http://wingolog.org/software/guile-charting/")
(synopsis "Create charts and graphs in Guile")
(description
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 149720e5e8..a55a5456af 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -22,10 +22,12 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages ghostscript) ;lcms
#:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
#:use-module (guix packages)
#:use-module (guix download)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake))
(define-public libpng
(package
@@ -146,3 +148,68 @@ the W3C's XML-based Scaleable Vector Graphic (SVG) format.")
;; 'COPYING' is the GPLv2, but file headers say LGPLv2.0+.
(license license:lgpl2.0+)))
+
+(define-public jbig2dec
+ (package
+ (name "jbig2dec")
+ (version "0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri ;; The link on the homepage is dead.
+ (string-append "http://distfiles.gentoo.org/distfiles/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1ffhgmf2fqzk0h4k736pp06z7q5y4x41fg844bd6a9vgncq86bby"))
+ (patches (list (search-patch "jbig2dec-ignore-testtest.patch")))))
+
+ (build-system gnu-build-system)
+ (synopsis "Decoder of the JBIG2 image compression format")
+ (description
+ "JBIG2 is designed for lossy or lossless encoding of 'bilevel'
+(1-bit monochrome) images at moderately high resolution, and in
+particular scanned paper documents. In this domain it is very
+efficient, offering compression ratios on the order of 100:1.
+
+This is a decoder only implementation, and currently is in the alpha
+stage, meaning it doesn't completely work yet. However, it is
+maintaining parity with available encoders, so it is useful for real
+work.")
+ (home-page "http://jbig2dec.sourceforge.net/")
+ (license license:gpl2+)))
+
+(define-public openjpeg
+ (package
+ (name "openjpeg")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://openjpeg.googlecode.com/files/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1n05yrmscpgksrh2kfh12h18l0lw9j03mgmvwcg3hm8m0lwgak9k"))))
+
+ (build-system cmake-build-system)
+ (arguments
+ ;; Trying to run `$ make check' results in a no rule fault.
+ '(#:tests? #f))
+ (inputs
+ `(("lcms" ,lcms)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("zlib" ,zlib)))
+ (synopsis "JPEG 2000 codec")
+ (description
+ "The OpenJPEG library is a JPEG 2000 codec written in C. It has
+been developed in order to promote the use of JPEG 2000, the new
+still-image compression standard from the Joint Photographic Experts
+Group (JPEG).
+
+In addition to the basic codec, various other features are under
+development, among them the JP2 and MJ2 (Motion JPEG 2000) file formats,
+an indexing tool useful for the JPIP protocol, JPWL-tools for
+error-resilience, a Java-viewer for j2k-images, ...")
+ (home-page "http://jbig2dec.sourceforge.net/")
+ (license license:bsd-2)))
diff --git a/gnu/packages/libcanberra.scm b/gnu/packages/libcanberra.scm
index 1106a8aa83..764c3272a2 100644
--- a/gnu/packages/libcanberra.scm
+++ b/gnu/packages/libcanberra.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,7 +25,9 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xiph))
@@ -35,19 +38,24 @@
(source
(origin
(method url-fetch)
- (uri (string-append "http://0pointer.de/lennart/projects/libcanberra/libcanberra-"
- version ".tar.xz"))
+
+ ;; This used to be at 0pointer.de but it vanished.
+ (uri (string-append
+ "http://pkgs.fedoraproject.org/repo/pkgs/libcanberra/libcanberra-"
+ version ".tar.xz/34cb7e4430afaf6f447c4ebdb9b42072/libcanberra-"
+ version ".tar.xz"))
(sha256
(base32
"0wps39h8rx2b00vyvkia5j40fkak3dpipp1kzilqla0cgvk73dn2"))))
(build-system gnu-build-system)
(inputs
- ;; FIXME: Add optional inputs udev and pulse.
`(("alsa-lib" ,alsa-lib)
("gstreamer" ,gstreamer)
("gtk+" ,gtk+)
("libtool" ,libtool)
- ("libvorbis" ,libvorbis)))
+ ("libvorbis" ,libvorbis)
+ ("pulseaudio" ,pulseaudio)
+ ("udev" ,eudev)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "http://0pointer.de/lennart/projects/libcanberra/")
@@ -59,3 +67,23 @@ Specifications, for generating event sounds on free desktops, such as
GNOME. It comes with several backends (ALSA, PulseAudio, OSS, GStreamer,
null) and is designed to be portable.")
(license lgpl2.1+)))
+
+(define-public sound-theme-freedesktop
+ (package
+ (name "sound-theme-freedesktop")
+ (version "0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://people.freedesktop.org/~mccann/dist/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "054abv4gmfk9maw93fis0bf605rc56dah7ys5plc4pphxqh8nlfb"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("intltool" ,intltool)))
+ (synopsis "Audio samples for use as a desktop sound theme")
+ (description
+ "This package provides audio samples that can be used by libcanberra as
+sounds for various system events.")
+ (license #f)
+ (home-page "http://www.freedesktop.org/wiki/Specifications/sound-theme-spec/")))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index dd4ed85a64..561275c05f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -190,7 +190,7 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
#f)))
(define-public linux-libre
- (let* ((version "3.16.2")
+ (let* ((version "3.16.3")
(build-phase
'(lambda* (#:key system inputs #:allow-other-keys #:rest args)
;; Apply the neat patch.
@@ -263,7 +263,7 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
(uri (linux-libre-urls version))
(sha256
(base32
- "1p08cqy6427yi808fpbwbb4zbwhnkibj2i1wbrfa5rjhd4vnnffz"))))
+ "1480wnk1j18rxhp8hi7dd4d706lkgplwhvskx3z2mj39vg46v1zk"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)
("bc" ,bc)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5f30afe433..af9feff040 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -273,7 +273,7 @@ plotting engine by third-party applications like Octave.")
%standard-phases)))
(outputs '("out" "bin" "lib" "include"))
(home-page "http://www.hdfgroup.org")
- (synopsis "Management suite for extremely large and complex data")
+ (synopsis "Management suite for extremely large and complex data")
(description "HDF5 is a suite that makes possible the management of
extremely large and complex data collections.")
(license (license:x11-style
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index bcd4c196c5..b4e48ccc4c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -23,7 +23,11 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
- #:use-module (gnu packages perl))
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages curl))
(define-public ocaml
(package
@@ -78,3 +82,64 @@ an emphasis on expressiveness and safety. Developed for more than 20 years at
Inria it benefits from one of the most advanced type systems and supports
functional, imperative and object-oriented styles of programming.")
(license (list qpl gpl2))))
+
+(define-public opam
+ (package
+ (name "opam")
+ (version "1.1.1")
+ (source (origin
+ (method url-fetch)
+ ;; Use the '-full' version, which includes all the dependencies.
+ (uri (string-append
+ "https://github.com/ocaml/opam/releases/download/"
+ version "/opam-full-" version ".tar.gz")
+ ;; (string-append "https://github.com/ocaml/opam/archive/"
+ ;; version ".tar.gz")
+ )
+ (sha256
+ (base32
+ "1frzqkx6yn1pnyd9qz3bv3rbwv74bmc1xji8kl41r1dkqzfl3xqv"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(;; Sometimes, 'make -jX' would fail right after ./configure with
+ ;; "Fatal error: exception End_of_file".
+ #:parallel-build? #f
+
+ ;; For some reason, 'ocp-build' needs $TERM to be set.
+ #:make-flags '("TERM=screen")
+ #:test-target "tests"
+
+ ;; FIXME: There's an obscure test failure:
+ ;; …/_obuild/opam/opam.asm install P1' failed.
+ #:tests? #f
+
+ #:phases (alist-cons-before
+ 'build 'pre-build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* "src/core/opamSystem.ml"
+ (("\"/bin/sh\"")
+ (string-append "\"" bash "/bin/sh\"")))))
+ (alist-cons-before
+ 'check 'pre-check
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (and (system "git config --global user.email guix@gnu.org")
+ (system "git config --global user.name Guix")))
+ %standard-phases))))
+ (native-inputs
+ `(("git" ,git) ;for the tests
+ ("python" ,python))) ;for the tests
+ (inputs
+ `(("ocaml" ,ocaml)
+ ("ncurses" ,ncurses)
+ ("curl" ,curl)))
+ (home-page "http://opam.ocamlpro.com/")
+ (synopsis "Package manager for OCaml")
+ (description
+ "OPAM is a tool to manage OCaml packages. It supports multiple
+simultaneous compiler installations, flexible package constraints, and a
+Git-friendly development workflow.")
+
+ ;; The 'LICENSE' file waives some requirements compared to LGPLv3.
+ (license lgpl3)))
diff --git a/gnu/packages/ots.scm b/gnu/packages/ots.scm
index cd2bf8585b..4404841375 100644
--- a/gnu/packages/ots.scm
+++ b/gnu/packages/ots.scm
@@ -45,6 +45,10 @@
(list (search-patch "ots-no-include-missing-file.patch")))))
(build-system gnu-build-system)
+ (arguments
+ ;; With '-jN', the rule to build the 'ots' command can be triggered
+ ;; before libots-1.la has been built.
+ '(#:parallel-build? #f))
(inputs
`(("glib" ,glib)
("popt" ,popt)
diff --git a/gnu/packages/patches/jbig2dec-ignore-testtest.patch b/gnu/packages/patches/jbig2dec-ignore-testtest.patch
new file mode 100644
index 0000000000..1bf8f7ad76
--- /dev/null
+++ b/gnu/packages/patches/jbig2dec-ignore-testtest.patch
@@ -0,0 +1,14 @@
+Do not run the "testtest script", it doesn't seem to do anything and reports
+failiute. TODO: Actually fix the test instead of ignoring it.
+
+--- a/Makefile.in 2010-02-02 20:13:56.000000000 +0100
++++ b/Makefile.in 2014-09-13 17:50:10.957816767 +0200
+@@ -181,7 +181,7 @@
+
+ MAINTAINERCLEANFILES = config_types.h.in
+
+-TESTS = test_sha1 test_jbig2dec.py test_huffman test_arith
++TESTS = test_sha1 test_huffman test_arith
+
+ test_sha1_SOURCES = sha1.c sha1.h
+ test_sha1_CFLAGS = -DTEST
diff --git a/gnu/packages/patches/mupdf-buildsystem-fix.patch b/gnu/packages/patches/mupdf-buildsystem-fix.patch
new file mode 100644
index 0000000000..0b17dda911
--- /dev/null
+++ b/gnu/packages/patches/mupdf-buildsystem-fix.patch
@@ -0,0 +1,69 @@
+Since openjpeg doesn't seem to ship with a .pc file, provide an alternative.
+
+--- a/ojp2_cppflags.sh 1970-01-01 01:00:00.000000000 +0100
++++ b/ojp2_cppflags.sh 2014-09-13 22:56:38.842418777 +0200
+@@ -0,0 +1,7 @@
++#!/bin/sh
++
++# Return the preprocessor flags to link against openjpeg.
++
++cpppath=$(echo ${NIX_STORE}/*-openjpeg-*/include/openjpeg-*)
++
++echo -I$cpppath
+
+--- a/ojp2_ldflags.sh 1970-01-01 01:00:00.000000000 +0100
++++ b/ojp2_ldflags.sh 2014-09-13 22:56:38.842418777 +0200
+@@ -0,0 +1,7 @@
++#!/bin/sh
++
++# Return the linker flags to link against openjpeg.
++
++ldpath=$(echo ${NIX_STORE}/*-openjpeg-*/lib)
++
++echo -L$ldpath -lopenjp2
+
+Make use of the above alternatives, compile with gcc.
+
+--- a/Makerules 2014-09-14 09:13:40.729149860 +0200
++++ b/Makerules 2014-09-14 09:17:06.425156595 +0200
+@@ -75,12 +75,14 @@
+
+ SYS_FREETYPE_CFLAGS = $(shell pkg-config --cflags freetype2)
+ SYS_FREETYPE_LIBS = $(shell pkg-config --libs freetype2)
+-SYS_OPENJPEG_CFLAGS = $(shell pkg-config --cflags libopenjp2)
+-SYS_OPENJPEG_LIBS = $(shell pkg-config --libs libopenjp2)
++SYS_OPENJPEG_CFLAGS = $(shell ./ojp2_cppflags.sh)
++SYS_OPENJPEG_LIBS = $(shell ./ojp2_ldflags.sh)
+ SYS_JBIG2DEC_LIBS = -ljbig2dec
+ SYS_JPEG_LIBS = -ljpeg
+ SYS_ZLIB_LIBS = -lz
+
++CC = gcc
++
+ endif
+
+ # The following section is an example of how to simply do cross-compilation
+
+Remove the -x11 from the built binaries, since X11 is implied on GNU. (This
+might change when Wayland gets more popular)
+
+--- a/Makefile 2014-06-10 17:09:28.000000000 +0200
++++ b/Makefile 2014-09-14 09:57:10.381235299 +0200
+@@ -255,7 +255,7 @@
+ $(LINK_CMD)
+
+ ifeq "$(HAVE_X11)" "yes"
+-MUVIEW_X11 := $(OUT)/mupdf-x11
++MUVIEW_X11 := $(OUT)/mupdf
+ MUVIEW_X11_OBJ := $(addprefix $(OUT)/platform/x11/, x11_main.o x11_image.o pdfapp.o)
+ $(MUVIEW_X11_OBJ) : $(FITZ_HDR) $(PDF_HDR)
+ $(MUVIEW_X11) : $(MUPDF_LIB) $(THIRD_LIBS)
+@@ -263,7 +263,7 @@
+ $(LINK_CMD) $(X11_LIBS)
+
+ ifeq "$(HAVE_CURL)" "yes"
+-MUVIEW_X11_CURL := $(OUT)/mupdf-x11-curl
++MUVIEW_X11_CURL := $(OUT)/mupdf-curl
+ MUVIEW_X11_CURL_OBJ := $(addprefix $(OUT)/platform/x11/curl/, x11_main.o x11_image.o pdfapp.o curl_stream.o)
+ $(MUVIEW_X11_CURL_OBJ) : $(FITZ_HDR) $(PDF_HDR)
+ $(MUVIEW_X11_CURL) : $(MUPDF_LIB) $(THIRD_LIBS) $(CURL_LIB)
diff --git a/gnu/packages/patches/valgrind-glibc.patch b/gnu/packages/patches/valgrind-glibc.patch
deleted file mode 100644
index 47a415bb8f..0000000000
--- a/gnu/packages/patches/valgrind-glibc.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Accept glibc 2.19 as valid.
-
---- a/configure 2013-10-10 22:27:20.331223000 +0200
-+++ b/configure 2013-10-10 22:27:55.055223000 +0200
-@@ -6604,6 +6604,16 @@
- DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
- DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
- ;;
-+ 2.19)
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.19 family" >&5
-+$as_echo "2.19 family" >&6; }
-+
-+$as_echo "#define GLIBC_2_18 1" >>confdefs.h
-+
-+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
-+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
-+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
-+ ;;
- darwin)
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: Darwin" >&5
- $as_echo "Darwin" >&6; }
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 82331a1d0a..c3cb755f4d 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages curl)
#:use-module (srfi srfi-1))
(define-public poppler
@@ -159,3 +160,69 @@ it easy to modify them and write the changes to disk. It is primarily useful
for applications that wish to do lower level manipulation of PDF, such as
extracting content or merging files.")
(license license:lgpl2.0+)))
+
+(define-public mupdf
+ (package
+ (name "mupdf")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://mupdf.com/downloads/" name "-" version
+ "-source.tar.gz"))
+ (sha256
+ (base32 "0sl47zqf4c9fhs4h5zg046vixjmwgy4vhljhr5g4md733nash7z4"))
+ (patches
+ (list (search-patch "mupdf-buildsystem-fix.patch")))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Don't build the bundled-in third party libraries.
+ (delete-file-recursively "thirdparty")
+
+ ;; Make the scripts for finding openjpeg build details executable.
+ (chmod "ojp2_cppflags.sh" #o0755)
+ (chmod "ojp2_ldflags.sh" #o0755)))))
+
+ (build-system gnu-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("freetype" ,freetype)
+ ("jbig2dec" ,jbig2dec)
+ ("libjpeg" ,libjpeg)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("openjpeg" ,openjpeg)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (arguments
+ ;; Trying to run `$ make check' results in a no rule fault.
+ '(#:tests? #f
+
+ #:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (srfi srfi-1))
+ #:phases (alist-replace
+ 'build
+ (lambda _ (zero? (system* "make" "XCFLAGS=-fpic")))
+ (alist-replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "make" (string-append "prefix=" out)
+ "install"))))
+ (alist-delete 'configure %standard-phases)))))
+ (home-page "http://mupdf.com")
+ (synopsis "Lightweight PDF viewer and toolkit")
+ (description
+ "MuPDF is a C library that implements a PDF and XPS parsing and
+rendering engine. It is used primarily to render pages into bitmaps,
+but also provides support for other operations such as searching and
+listing the table of contents and hyperlinks.
+
+The library ships with a rudimentary X11 viewer, and a set of command
+line tools for batch rendering (pdfdraw), examining the file structure
+(pdfshow), and rewriting files (pdfclean).")
+ (license license:agpl3+)))
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index e37f7c07e3..b17ee6987f 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -121,7 +121,14 @@ rates. ")
version ".tar.xz"))
(sha256
(base32
- "0fgrr8v7yfh0byhzdv4c87v9lkj8g7gpjm8r9xrbvpa92a5kmhcr"))))
+ "0fgrr8v7yfh0byhzdv4c87v9lkj8g7gpjm8r9xrbvpa92a5kmhcr"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Disable console-kit support by default since it's deprecated
+ ;; anyway.
+ '(substitute* "src/daemon/default.pa.in"
+ (("load-module module-console-kit" all)
+ (string-append "#" all "\n"))))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--localstatedir=/var" ;"--sysconfdir=/etc"
diff --git a/gnu/packages/skribilo.scm b/gnu/packages/skribilo.scm
index e9c213cbb2..6971e792d0 100644
--- a/gnu/packages/skribilo.scm
+++ b/gnu/packages/skribilo.scm
@@ -43,6 +43,22 @@
'(#:configure-flags (list (string-append "--with-guilemoduledir="
(assoc-ref %outputs "out")
"/share/guile/site/2.0"))
+
+ #:phases (alist-cons-before
+ 'configure 'pre-configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Make sure the 'skribilo' command gets to see
+ ;; Guile-Reader, even if Guile-Reader is not in the search
+ ;; path.
+ (let ((reader (assoc-ref inputs "guile-reader")))
+ (substitute* "src/skribilo.in"
+ (("^exec (.*) -c" _ things)
+ (string-append "exec " things
+ " -L " reader "/share/guile/site/2.0"
+ " -C " reader "/share/guile/site/2.0"
+ " -c")))))
+ %standard-phases)
+
#:parallel-build? #f))
;; TODO: Add Ploticus.
(inputs `(("guile" ,guile-2.0)
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index d7ac10cb16..099bad25f9 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -161,8 +161,8 @@ X11 GUIs.")
(home-page "http://www.tcl.tk/")
(synopsis "Graphical user interface toolkit for Tcl")
(description
- "Tk is a graphical toolkit for building graphical user interfaces
-(GUIs) in the Tcl language.")
+ "Tk is a graphical toolkit for building graphical user
+interfaces (GUIs) in the Tcl language.")
(license (package-license tcl))))
(define-public perl-tk
@@ -185,7 +185,10 @@ X11 GUIs.")
("libjpeg" ,libjpeg)))
(arguments
`(#:make-maker-flags `(,(string-append
- "X11=" (assoc-ref %build-inputs "libx11")))))
+ "X11=" (assoc-ref %build-inputs "libx11")))
+
+ ;; Fails to build in parallel: <http://bugs.gnu.org/18262>.
+ #:parallel-build? #f))
(synopsis "Graphical user interface toolkit for Perl")
(description
"Tk is a Graphical User Interface ToolKit.")
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 183adb0271..82e3b80f7f 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,15 +28,14 @@
(define-public valgrind
(package
(name "valgrind")
- (version "3.9.0")
+ (version "3.10.0")
(source (origin
(method url-fetch)
(uri (string-append "http://valgrind.org/downloads/valgrind-"
version ".tar.bz2"))
(sha256
(base32
- "1w6n5qvxy2ssbczcl1c2yd2ggjn3ipay2hvpn10laly2dfh73bz6"))
- (patches (list (search-patch "valgrind-glibc.patch")))))
+ "1jgd42vsx0bcblp91bd61hd5wpy0gghh09wxgm65m666vy17y103"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-after