aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/databases.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 9e7c31faf6..cb6cf688ff 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3113,6 +3113,44 @@ is designed to have a low barrier to entry.")
(define-public python2-rq
(package-with-python2 python-rq))
+(define-public python-rq-scheduler
+ (package
+ (name "python-rq-scheduler")
+ (version "0.10.0")
+ (home-page "https://github.com/rq/rq-scheduler")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xg6yazqs5kbr2ayvhvljs1h5vgx5k5dds613fmhswln7gglf9hk"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'check 'start-redis
+ (lambda _
+ (invoke "redis-server" "--daemonize" "yes")))
+ (replace 'check
+ (lambda _
+ (substitute* "run_tests.py"
+ (("/usr/bin/env")
+ (which "env")))
+ (invoke "./run_tests.py"))))))
+ (native-inputs
+ `(("redis" ,redis)
+ ("which" ,which)))
+ (propagated-inputs
+ `(("python-croniter" ,python-croniter)
+ ("python-rq" ,python-rq)))
+ (synopsis "Job scheduling capabilities for RQ (Redis Queue)")
+ (description
+ "This package provides job scheduling capabilities to @code{python-rq}
+(Redis Queue).")
+ (license license:expat)))
+
(define-public python-trollius-redis
(package
(name "python-trollius-redis")