aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 2df6631e2a..111de2b65a 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4639,6 +4639,7 @@ cannot be adequately worked around on the client side of the wire.")
(define-public libxtst
(package
(name "libxtst")
+ (replacement libxtst/fixed)
(version "1.2.2")
(source
(origin
@@ -4674,6 +4675,13 @@ The RECORD extension supports the recording and reporting of all core X
protocol and arbitrary X extension protocol.")
(license license:x11)))
+(define libxtst/fixed
+ (package
+ (inherit libxtst)
+ (source (origin
+ (inherit (package-source libxtst))
+ (patches (search-patches
+ "libxtst-CVE-2016-7951-CVE-2016-7952.patch"))))))
(define-public libxv
(package