aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm138
1 files changed, 121 insertions, 17 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fda61aff67..801e5e459b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2019 nee <nee@cock.li>
;;; Copyright © 2019 Yoshinori Arai <kumagusu08@gmail.com>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -211,14 +212,14 @@ which can be read by any architecture.")
(define-public xorgproto
(package
(name "xorgproto")
- (version "2019.1")
+ (version "2019.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://xorg/individual/proto/"
"xorgproto-" version ".tar.bz2"))
(sha256
(base32
- "16yll1kaffnslik5sizlw3qrigj1gpsgfgyq6903g3mwdixamnm6"))))
+ "13kvir8dz9dvzhvyfndpff1z7k8h14s7kkl7mbl427andhax1v26"))))
(build-system gnu-build-system)
(propagated-inputs
;; To get util-macros in (almost?) all package inputs.
@@ -1039,6 +1040,8 @@ of new capabilities and controls for text keyboards.")
(base32
"0hvjfhrcym770cr0zpqajdy3cda30aiwbjzv16iafkqkbl090gr5"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(inputs
`(("xorgproto" ,xorgproto)
("libxext" ,libxext)
@@ -1065,6 +1068,8 @@ of new capabilities and controls for text keyboards.")
(base32
"1ir0j92mnd1nk37mrv9bz5swnccqldicgszvfsh62jd14q6k115q"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("xorgproto" ,xorgproto)))
(home-page "https://www.x.org/")
@@ -1092,6 +1097,8 @@ synchronization between the X server and direct-rendering clients.")
(base32
"0y90170dp8wsidr1dzza0grxr1lfh30ji3b5vkjz4j6x1n0wxz1c"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(inputs
`(("zlib" ,zlib)
("xorgproto" ,xorgproto)))
@@ -1278,6 +1285,8 @@ with the Cygwin XWin server when running X11 in a rootless mode.")
(base32
"13sfcglvz87vl58hd9rszwr73z0z4nwga3c12rfh7f5s2ln8l8dk"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
;; xcomposite.pc refers to all these.
`(("xorgproto" ,xorgproto)
@@ -1307,6 +1316,8 @@ with the Cygwin XWin server when running X11 in a rootless mode.")
(base32
"0ab53h0rkq721ihk5hi469x500f3pgbkm1wy01yf24x5m923nli0"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(inputs
`(("libbsd" ,libbsd)
("xorgproto" ,xorgproto)))
@@ -1333,6 +1344,8 @@ with the Cygwin XWin server when running X11 in a rootless mode.")
(base32
"05lja9s54090xwh31r0bqms4v3pimng5xr09g2rdnafx2vk6hp12"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
;; xft.pc refers to all these.
`(("libxrender" ,libxrender)
@@ -1367,6 +1380,8 @@ configuration files.")
(base32
"1irq9crvscd3yb8sr802dhvvfr35jdy1n2yz094xplmd42mbv3bm"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(inputs
`(("libx11" ,libx11)))
(native-inputs
@@ -1392,6 +1407,8 @@ configuration files.")
(base32
"0cdpqnx6258i4l6qhphvkdiyspysg0i5caqjy820kp63wwjk4d4w"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(inputs
`(("libxt" ,libxt)
("xorgproto" ,xorgproto)
@@ -1424,6 +1441,8 @@ treat it as part of their software base when porting.")
(base32
"1v5xaiw4zlhxspvx76y3hq4wpxv7mpj6parqnwdqvpj8vbinsspx"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(inputs
`(("gettext" ,gettext-minimal)
("libxt" ,libxt)
@@ -1452,6 +1471,8 @@ treat it as part of their software base when porting.")
(base32
"1m0jr0lbz9ixpp9ihk68349q0i7ry2379lnfzdy4mrl86ijc2xgz"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(inputs
`(("xorgproto" ,xorgproto)
("libxext" ,libxext)
@@ -1479,6 +1500,8 @@ treat it as part of their software base when porting.")
(base32
"1y4vx1vabg7j9hamp0vrfrax5b0lmgm3h0lbgbb3hnkv3dd0f5zr"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(inputs
`(("libxext" ,libxext)
("libx11" ,libx11)))
@@ -1504,6 +1527,8 @@ treat it as part of their software base when porting.")
(sha256
(base32 "00vjvcdlc1sga251jkxn6gkxmx9h5n290ffxxpa40qbca1gvr61b"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("xorgproto" ,xorgproto)))
(inputs
@@ -4551,6 +4576,13 @@ cannot be adequately worked around on the client side of the wire.")
(base32
"0azqxllcsfxc3ilhz6kwc6x7m8wc477p59ir9p0yrsldx766zbar"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-static"
+ ;; Disable zero malloc check that fails when cross-compiling.
+ ,@(if (%current-target-system)
+ '("--disable-malloc0returnsnull")
+ '()))))
(propagated-inputs
`(("xorgproto" ,xorgproto)))
(inputs
@@ -4580,6 +4612,8 @@ cannot be adequately worked around on the client side of the wire.")
(base32
"086p0axqj57nvkaqa6r00dnr9kyrn1m8blgf0zjy25zpxkbxn200"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("xorgproto" ,xorgproto)))
(inputs
@@ -4636,6 +4670,13 @@ cannot be adequately worked around on the client side of the wire.")
(base32
"0j89cnb06g8x79wmmnwzykgkkfdhin9j7hjpvsxwlr3fz1wmjvf0"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-static"
+ ;; Disable zero malloc check that fails when cross-compiling.
+ ,@(if (%current-target-system)
+ '("--disable-malloc0returnsnull")
+ '()))))
(propagated-inputs
`(("xorgproto" ,xorgproto)))
(inputs
@@ -4662,6 +4703,8 @@ cannot be adequately worked around on the client side of the wire.")
(base32
"012jpyj7xfm653a9jcfqbzxyywdmwb2b5wr1dwylx14f3f54jma6"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("libxi" ,libxi)
("xorgproto" ,xorgproto)))
@@ -4699,6 +4742,8 @@ protocol and arbitrary X extension protocol.")
(base32
"125hn06bd3d8y97hm2pbf5j55gg4r2hpd3ifad651i4sr7m16v6j"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("xorgproto" ,xorgproto)))
(inputs
@@ -4727,8 +4772,21 @@ protocol and arbitrary X extension protocol.")
"0c3563kw9fg15dpgx4dwvl12qz6sdqdns1pxa574hc7i5m42mman"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-configure
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.sub and config.guess:
+ (for-each (lambda (file)
+ (install-file (string-append
+ (assoc-ref
+ (or native-inputs inputs) "automake")
+ "/share/automake-"
+ ,(version-major+minor
+ (package-version automake))
+ "/" file) "."))
+ '("config.sub" "config.guess"))
+ #t))
(add-after 'install 'wrap-mkfontdir
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (string-append (assoc-ref outputs "out")
@@ -4740,7 +4798,8 @@ protocol and arbitrary X extension protocol.")
(inputs
`(("mkfontscale" ,mkfontscale)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("automake" ,automake))) ;For up to date 'config.guess' and 'config.sub'.
(home-page "https://www.x.org/wiki/")
(synopsis "Create an index of X font files in a directory")
(description
@@ -4797,6 +4856,8 @@ common definitions and porting layer.")
(base32
"0j638yvmyna2k4mz465jywgdybgdchdqppfx6xfazg7l5khxr1kg"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("xorgproto" ,xorgproto)))
(inputs
@@ -4825,6 +4886,8 @@ common definitions and porting layer.")
(base32
"1v3krc6x0zliaa66qq1bf9j60x5nqfy68v8axaiglxpnvgqcpy6c"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("xorgproto" ,xorgproto)))
(native-inputs
@@ -4851,6 +4914,8 @@ an X Window System display.")
(base32
"1miana3y4hwdqdparsccmygqr3ic3hs5jrqfzp70hvi2zwxd676y"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("xorgproto" ,xorgproto)))
(inputs
@@ -4877,6 +4942,8 @@ an X Window System display.")
(base32
"0hiji1bvpl78aj3a3141hkk353aich71wv8l5l2z51scfy878zqs"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("freetype" ,freetype)
("libfontenc" ,libfontenc)
@@ -4924,6 +4991,8 @@ new API's in libXft, or the legacy API's in libX11.")
(base32
"0q8hz3slga3w3ch8wp0k7ay9ilhz315qnab0w1y2x9w3cf7hv8rn"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("xorgproto" ,xorgproto)
("libx11" ,libx11)
@@ -4951,6 +5020,8 @@ new API's in libXft, or the legacy API's in libX11.")
(base32
"08z0mqywrm7ij8bxlfrx0d2wy6kladdmkva1nw5k6qix82z0xsla"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
;; In accordance with xrandr.pc.
`(("libx11" ,libx11)
@@ -4980,6 +5051,8 @@ new API's in libXft, or the legacy API's in libX11.")
(base32
"1kbdjsvkm5l7axv7g477qj18sab2wnqhliy6197syzizgfbsfgbb"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("libxv" ,libxv)))
(inputs
@@ -5008,6 +5081,8 @@ new API's in libXft, or the legacy API's in libX11.")
(base32
"0mydhlyn72i7brjwypsqrpkls3nm6vxw0li8b2nw0caz7kwjgvmg"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("libxext" ,libxext)
("xorgproto" ,xorgproto)))
@@ -5049,7 +5124,8 @@ protocol.")
`(("pkg-config" ,pkg-config)
("python" ,python-minimal-wrapper)))
(arguments
- `(#:configure-flags '("--enable-xkb")))
+ `(#:configure-flags '("--enable-xkb"
+ "--disable-static")))
(home-page "https://xcb.freedesktop.org/")
(synopsis "The X C Binding (XCB) library")
(description
@@ -5238,7 +5314,7 @@ draggable titlebars and borders.")
(define-public libx11
(package
(name "libx11")
- (version "1.6.8")
+ (version "1.6.9")
(source
(origin
(method url-fetch)
@@ -5248,21 +5324,29 @@ draggable titlebars and borders.")
".tar.bz2"))
(sha256
(base32
- "1mbkwhhprhf49s2iwx7kiliprsdvd690zk44x3h53ql9q52si2dj"))))
+ "1ldyn9c6pyx54sxzaw120n3q42rqi7b503aqmyjky6fn038fiiww"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;8 MiB of man pages + XML
(arguments
- '(#:configure-flags (list (string-append "--mandir="
- (assoc-ref %outputs "doc")
- "/share/man"))))
+ `(#:configure-flags
+ (list (string-append "--mandir="
+ (assoc-ref %outputs "doc")
+ "/share/man")
+ "--disable-static"
+
+ ;; Disable zero malloc check that fails when cross-compiling.
+ ,@(if (%current-target-system)
+ '("--disable-malloc0returnsnull")
+ '()))))
(propagated-inputs
`(("xorgproto" ,xorgproto)
("libxcb" ,libxcb)))
(inputs
`(("xtrans" ,xtrans)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("xorgproto" ,xorgproto)))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg Core X11 protocol client library")
(description "Xorg Core X11 protocol client library.")
@@ -5285,6 +5369,8 @@ draggable titlebars and borders.")
(base32
"10l7c9fm0jmpkm9ab9dz8r6m1pr87vvgqjnbx1psz50h4pwfklrs"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("libx11" ,libx11)
("libxrender" ,libxrender)
@@ -5327,7 +5413,8 @@ draggable titlebars and borders.")
(arguments
'(#:configure-flags (list (string-append "--mandir="
(assoc-ref %outputs "doc")
- "/share/man"))))
+ "/share/man")
+ "--disable-static")))
(propagated-inputs
`(("libx11" ,libx11)
("libice" ,libice)
@@ -5357,6 +5444,8 @@ draggable titlebars and borders.")
(base32
"1kdhxplwrn43d9jp3v54llp05kwx210lrsdvqb6944jp29rhdy4f"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("libxext" ,libxext)
("libxmu" ,libxmu)
@@ -5416,6 +5505,8 @@ keyboard focus, and user-specified key and pointer button bindings.")
(base32
"1sahmrgbpyki4bb72hxym0zvxwnycmswsxiisgqlln9vrdlr9r26"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("libxcb" ,libxcb)))
(native-inputs
@@ -5452,6 +5543,8 @@ The XCB util module provides the following libraries:
(base32
"0krr4rcw6r42cncinzvzzdqnmxk3nrgpnadyg2h8k9x10q3hm885"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(native-inputs
`(("m4" ,m4)
("pkg-config" ,pkg-config)))
@@ -5534,6 +5627,8 @@ numbers.")
(base32
"1z1gxacg7q4cw6jrd26gvi5y04npsyavblcdad1xccc8swvnmf9d"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("libxcb" ,libxcb)))
(inputs
@@ -5568,6 +5663,8 @@ The XCB util-image module provides the following library:
(base32
"1nbd45pzc1wm6v5drr5338j4nicbgxa5hcakvsvm5pnyy47lky0f"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("libxcb" ,libxcb)))
(native-inputs
@@ -5600,6 +5697,8 @@ The XCB util-keysyms module provides the following library:
(base32
"0nza1csdvvxbmk8vgv8vpmq7q8h05xrw3cfx9lwxd1hjzd47xsf6"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("libxcb" ,libxcb)))
(native-inputs
@@ -5632,6 +5731,8 @@ The XCB util-renderutil module provides the following library:
(base32
"0gra7hfyxajic4mjd63cpqvd20si53j1q3rbdlkqkahfciwq3gr8"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(propagated-inputs
`(("libxcb" ,libxcb)))
(native-inputs
@@ -6384,25 +6485,28 @@ output.")
" ")))
#t))
(add-before 'build 'make-doubled-bdfs
- (lambda* (#:key inputs #:allow-other-keys)
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
(invoke "make" "-C" "Fonts"
"doubled_bdfs"
(string-append "SHELL="
- (assoc-ref inputs "bash")
+ (assoc-ref (or native-inputs inputs)
+ "bash")
"/bin/bash"))))
(replace 'install
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
(let ((out (assoc-ref %outputs "out")))
(invoke "make" "install-linux"
(string-append "prefix=" out)
(string-append "SHELL="
- (assoc-ref inputs "bash")
+ (assoc-ref (or native-inputs inputs)
+ "bash")
"/bin/bash"))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("bdftopcf" ,bdftopcf)
("bdfresize" ,bdfresize)
- ("sharutils" ,sharutils))) ;for 'uuencode'
+ ("sharutils" ,sharutils) ;for 'uuencode'
+ ("perl" ,perl)))
(inputs
`(("perl" ,perl))) ;used by 'ckbcomp'
(synopsis "Set up the Linux console font and keyboard")