aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm138
1 files changed, 67 insertions, 71 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 2192f61dc7..c8dd66b2e0 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -7,13 +7,13 @@
;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
;;; Copyright © 2019 L p R n d n <guix@lprndn.info>
;;; Copyright © 2019 Ingo Ruhnke <grumbel@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,6 +54,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages polkit)
#:use-module (gnu packages popt)
+ #:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages search)
@@ -100,7 +101,7 @@
(define-public libxfce4util
(package
(name "libxfce4util")
- (version "4.14.0")
+ (version "4.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -108,7 +109,7 @@
"/" name "-" version ".tar.bz2"))
(sha256
(base32
- "093338faqqsrlc8dkmzr7qv411ysxczg1wlg7s3gvhrfk6vpkb9j"))))
+ "10svnpc8ggasym1pfgh24bfr0ndqs6lc7v1wmpsizj0zbms8snb0"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -126,7 +127,7 @@ Xfce Desktop Environment.")
(define-public xfconf
(package
(name "xfconf")
- (version "4.14.4")
+ (version "4.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -134,12 +135,17 @@ Xfce Desktop Environment.")
"xfconf-" version ".tar.bz2"))
(sha256
(base32
- "0wszp93z64112jq5wm4133s64in2ndvnzbgsbn8dh7p5xhp64dyc"))))
+ "09al5bkq89b8pb3xyxnw0cnz6crxj8678ymwq2k9nzf60y812ak5"))))
(build-system gnu-build-system)
(arguments
'(#:phases
;; Run check after install phase to test dbus activation.
(modify-phases %standard-phases
+ ;; tests-end seems to hang forever
+ (add-before 'configure 'patchout-tests-end
+ (lambda _
+ (substitute* "tests/Makefile.in"
+ (("tests-end") ""))))
(add-after 'install 'custom-check
(lambda _
(setenv "HOME" (getenv "TMPDIR")) ; xfconfd requires a writable HOME
@@ -147,8 +153,15 @@ Xfce Desktop Environment.")
(setenv "XDG_DATA_DIRS" ; for finding org.xfce.Xfconf.service
(string-append %output "/share"))
;; For the missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0");
+ (setenv "DBUS_FATAL_WARNINGS" "0")
(invoke "dbus-launch" "make" "check")))
+ (add-after 'custom-check 'install-shell-completions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (etc (string-append out "/etc")))
+ (with-directory-excursion "completions"
+ (install-file "xfconf-query"
+ (string-append etc "/bash_completion.d"))))))
(delete 'check))))
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -172,7 +185,7 @@ storage system.")
(define-public libxfce4ui
(package
(name "libxfce4ui")
- (version "4.14.1")
+ (version "4.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -180,7 +193,7 @@ storage system.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "1npjhznmnckhnylsv3l7p1zvhckhmp9d7vifs8w12kdfmrg0fjf4"))))
+ "1anfj3n28abv9kbcpybs7q3k5g3c3d0r4xf4hyfqms2b9zlwj1lb"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -191,14 +204,11 @@ storage system.")
("gobject-introspection" ,gobject-introspection)))
(propagated-inputs
`(("gtk+-3" ,gtk+) ; required by libxfce4ui-2.pc
- ;; libxfce4kbd-private-2.pc refers to all these.
+ ;; libxfce4kbd-private-3.pc refers to all these.
("libxfce4util" ,libxfce4util)
("xfconf" ,xfconf)))
(inputs `(("libsm" ,libsm)
("libice" ,libice)
- ;; FIXME: required by libxfce4ui-1.pc, so should be propagated,
- ;; but will lead to a conflict with gtk+.
- ("gtk+-2" ,gtk+-2)
("startup-notification" ,startup-notification)))
(home-page "https://www.xfce.org/")
(synopsis "Widgets library for Xfce")
@@ -268,7 +278,7 @@ it to your needs by using several command line options.")
(define-public elementary-xfce-icon-theme
(package
(name "elementary-xfce-icon-theme")
- (version "0.15.1")
+ (version "0.15.2")
(source (origin
(method git-fetch)
(uri
@@ -278,7 +288,7 @@ it to your needs by using several command line options.")
(file-name (git-file-name name version))
(sha256
(base32
- "1rl15kh9c7qxw4pvwmw44fb4v3vwh6zin4wpx55bnvm5j76y6p3f"))))
+ "1g6vndqvp11c2kl5vkpzb1wxvr2pfb3hvqxjjdgx6qzq9x8zmiqk"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no check target
@@ -303,7 +313,7 @@ upstream occasionally.")
(define-public exo
(package
(name "exo")
- (version "0.12.11")
+ (version "4.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -311,21 +321,8 @@ upstream occasionally.")
"exo-" version ".tar.bz2"))
(sha256
(base32
- "1dp5s64g6572h9zvx9js7qc72s728qsd9y7hl7hg6rwaq0cjb2gc"))))
+ "1k5sfm9cmg8k5zzzv0wb2cciqwwklnpfzcpak7wa32lsxl7b0x8r"))))
(build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; exo won't find URI::Escape otherwise
- (add-after 'install 'wrap-exo-compose-mail
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (perl5lib (getenv "PERL5LIB")))
- (wrap-program (string-append out "/lib/xfce4/exo/exo-compose-mail")
- `("PERL5LIB" ":" prefix
- (,(string-append perl5lib ":" out
- "/lib/perl5/site_perl")))))
- #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
@@ -334,10 +331,7 @@ upstream occasionally.")
`(("gtk+-3" ,gtk+)
("libxfce4util" ,libxfce4util)))
(inputs
- `(;; FIXME Referred to in exo-1.pc but conflict with gtk+-3.
- ("gtk+-2" ,gtk+-2)
- ("libxfce4ui" ,libxfce4ui)
- ("perl-uri" ,perl-uri)))
+ `(("libxfce4ui" ,libxfce4ui)))
(home-page "https://www.xfce.org/")
(synopsis "Extension library for Xfce")
(description
@@ -350,7 +344,7 @@ development.")
(define-public garcon
(package
(name "garcon")
- (version "0.7.0")
+ (version "4.16.1")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -358,14 +352,13 @@ development.")
"garcon-" version ".tar.bz2"))
(sha256
(base32
- "08r4dfvdvl178cjajm7ww16lwb7jsfqh3yz614mn84c0a0dvdhw2"))))
+ "07fjsgdjqxbcm84ga3cl495782k381k6mwksyrks3zf1l8klk4c4"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
- ("glib:bin" ,glib "bin")))
- (inputs
- `(("gtk+-2" ,gtk+-2))) ; required by garcon-gtk2-1.pc
+ ("pkg-config" ,pkg-config)))
(propagated-inputs
`(("gtk+-3" ,gtk+) ; required by garcon-gtk3-1.pc
("libxfce4ui" ,libxfce4ui))) ; required by garcon-gtk3-1.pc
@@ -381,7 +374,7 @@ merging features essential for loading menus modified with menu editors.")
(define-public tumbler
(package
(name "tumbler")
- (version "0.2.9")
+ (version "4.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -389,7 +382,7 @@ merging features essential for loading menus modified with menu editors.")
"tumbler-" version ".tar.bz2"))
(sha256
(base32
- "1dh7h0jcbf8brvv9vwq4amnk6zgldl2ipdq3clzsx9p50dpr0235"))))
+ "0rmga1l7da0pjrs6jlyq1nfn513r543v7cchshrif1341knpy2wv"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -420,7 +413,7 @@ management D-Bus specification.")
(define-public xfce4-panel
(package
(name "xfce4-panel")
- (version "4.14.0")
+ (version "4.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -428,7 +421,7 @@ management D-Bus specification.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "1x3flv86jh9vqah7mr5mmfx2991mc6icsqjygsc3j88lgsyz7y6m"))
+ "0gf57hgx6v44bc2hj570inkafbi291scc6wbhmr6sc3xngp9m5sy"))
(patches (search-patches "xfce4-panel-plugins.patch"))))
(build-system gnu-build-system)
(arguments
@@ -577,7 +570,7 @@ keys for controlling the audio volume.")
(define-public xfce4-whiskermenu-plugin
(package
(name "xfce4-whiskermenu-plugin")
- (version "2.5.1")
+ (version "2.5.2")
(source
(origin
(method url-fetch)
@@ -585,7 +578,7 @@ keys for controlling the audio volume.")
"xfce4-whiskermenu-plugin/" (version-major+minor version) "/"
"xfce4-whiskermenu-plugin-" version ".tar.bz2"))
(sha256
- (base32 "09b9i68pf5ghq6dj55s4h3fj07jd5zpn1fghjwnnwxmakj54y1xj"))))
+ (base32 "05f53ycbszvw23g76pbdszfnqfk4f8w4imwfgljj140wzl50gxx6"))))
(build-system cmake-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -659,15 +652,16 @@ per window.")
(define-public xfce4-appfinder
(package
(name "xfce4-appfinder")
- (version "4.14.0")
+ (version "4.16.1")
(source (origin
(method url-fetch)
- (uri (string-append "http://archive.xfce.org/xfce/"
+ (uri (string-append "https://archive.xfce.org/src/xfce/"
+ name "/"
(version-major+minor version)
- "/src/" name "-" version ".tar.bz2"))
+ "/" name "-" version ".tar.bz2"))
(sha256
(base32
- "162dibl6ipp72x0s35yhk7kkzxd4qimagg5zdkkv5kjgjpa7bhby"))))
+ "1v77h5634n49idci2jiw0k7jjk0vzpsvgyx2fkp18l39jayykqxz"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -686,7 +680,7 @@ your system in categories, so you can quickly find and launch them.")
(define-public xfce4-session
(package
(name "xfce4-session")
- (version "4.14.2")
+ (version "4.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -694,7 +688,7 @@ your system in categories, so you can quickly find and launch them.")
"xfce4-session-" version ".tar.bz2"))
(sha256
(base32
- "1bwpylcn7x9i301yz45wvkzah9bncv9b44nf4hh9ln4i1jka9qzv"))
+ "1dqpgnq1hy9z170aapjglyp6jpyq1iqn5331nph727a82br77wi2"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -731,7 +725,7 @@ allows you to shut down the computer from Xfce.")
(define-public xfce4-settings
(package
(name "xfce4-settings")
- (version "4.14.0")
+ (version "4.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -739,7 +733,7 @@ allows you to shut down the computer from Xfce.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "0g0ipkg2fyg8r1z95ynx0xjr78bp49c2dwh4mli05nmb4gb40c70"))
+ "1hnx88a8xmi38mdf5gxdvx7n8yax1vzah8hy8g37bijlqx7l18b7"))
(patches (search-patches "xfce4-settings-defaults.patch"))))
(build-system gnu-build-system)
(arguments
@@ -758,7 +752,8 @@ allows you to shut down the computer from Xfce.")
("libxklavier" ,libxklavier)
("libxrandr" ,libxrandr)
("libxfce4ui" ,libxfce4ui)
- ("upower" ,upower)
+ ("upower" ,upower) ;; TODO needs upower-glib
+ ("python" ,python) ;; for xfce4-compose-mail
("xf86-input-libinput" ,xf86-input-libinput)))
(home-page "https://www.xfce.org/")
(synopsis "Xfce settings manager")
@@ -770,7 +765,7 @@ like appearance, display, keyboard and mouse settings.")
(define-public thunar
(package
(name "thunar")
- (version "1.8.16")
+ (version "4.16.2")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -778,13 +773,14 @@ like appearance, display, keyboard and mouse settings.")
"thunar-" version ".tar.bz2"))
(sha256
(base32
- "0k1w2zwa8z6sc8vi3frva74npks79x79n7q9p7ibwk7irfqkh4r2"))))
+ "1pbspa31q4kgydjzmssahq3k0wcy10ma466dlsd2y69nqjc0pab7"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
(inputs
`(("exo" ,exo)
+ ("gobject-introspection" ,gobject-introspection)
("libexif" ,libexif)
("libgudev" ,libgudev)
("libnotify" ,libnotify)
@@ -802,7 +798,7 @@ fast.")
(define-public thunar-volman
(package
(name "thunar-volman")
- (version "0.9.5")
+ (version "4.16.0")
(source
(origin
(method url-fetch)
@@ -810,7 +806,7 @@ fast.")
(version-major+minor version) "/"
"thunar-volman-" version ".tar.bz2"))
(sha256
- (base32 "0dqqkbhn43hhmhqyx1fnmawpvysdjzw6ln4ryf629wil6dlwd9vy"))))
+ (base32 "0zaliahfz9ci2md7g6w9mb7z5azi5n56gihbnwyzvds2n8cygh6j"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -833,7 +829,7 @@ and import the new pictures from your camera.")
(define-public xfwm4
(package
(name "xfwm4")
- (version "4.14.3")
+ (version "4.16.1")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -841,7 +837,7 @@ and import the new pictures from your camera.")
"xfwm4-" version ".tar.bz2"))
(sha256
(base32
- "1gw3fbiwraylarl1bqbvfh7nxlss5w8w0im5ahfg3a9mkrdfr6w2"))))
+ "133ip28v6j3x4l413d81ixsisf32sa0xzd54n0nn8g6p9fh4rcmm"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -863,7 +859,7 @@ on the screen.")
(define-public xfdesktop
(package
(name "xfdesktop")
- (version "4.14.3")
+ (version "4.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -871,7 +867,7 @@ on the screen.")
"xfdesktop-" version ".tar.bz2"))
(sha256
(base32
- "14sp5a4n21prwmh2l5mjq5fjaq7r2pbjxddfx4wzaix8867x1mq6"))
+ "1bjv2mpkv7zmpzssbvvzh0x4pn8cqm8dvhgsv5i1xwngzspsajwk"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -1007,7 +1003,7 @@ system resources, while still being visually appealing and user friendly.")
(define-public xfce4-power-manager
(package
(name "xfce4-power-manager")
- (version "1.7.1")
+ (version "4.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -1015,7 +1011,7 @@ system resources, while still being visually appealing and user friendly.")
"xfce4-power-manager-" version ".tar.bz2"))
(sha256
(base32
- "1ki088iyr266cfyq9bmmhhd27wrsrmbhsblyf4yqby03hlvqif3k"))))
+ "1wrvqiifaxsgcn1kh4vm2hwxi9lgm6mw4zrfld2zl0mm05y5i77b"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -1285,7 +1281,7 @@ A plugin for the Xfce panel is also available.")
(define-public xfce4-screensaver
(package
(name "xfce4-screensaver")
- (version "0.1.11")
+ (version "4.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/apps/"
@@ -1295,7 +1291,7 @@ A plugin for the Xfce panel is also available.")
version ".tar.bz2"))
(sha256
(base32
- "0xxcvvcch8bqd35ksq8l88a46xnidp59iq4ssyygki0a2vd20h41"))))
+ "13962rkc7nn3yigv1km8w0z7g41kj2bxmrrwx2f6gnv27qz18kbd"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1505,7 +1501,7 @@ precedence rules, and the following functions and common constants.")
(define-public xfce4-cpufreq-plugin
(package
(name "xfce4-cpufreq-plugin")
- (version "1.2.2")
+ (version "1.2.3")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/panel-plugins/"
@@ -1514,7 +1510,7 @@ precedence rules, and the following functions and common constants.")
"/xfce4-cpufreq-plugin-" version ".tar.bz2"))
(sha256
(base32
- "16748wxy8aa5cxga0dbfrq7kv40alg5yx967r2l6vjapv2w083sh"))))
+ "1g07rpbq61dbdz0zvvb0xz6ipympxadwknn5y5q3v85k0nr9qfbx"))))
(build-system gnu-build-system)
(native-inputs
`(("intltool" ,intltool)
@@ -1922,7 +1918,7 @@ freedesktop.org specification.")
(define-public xfce4-stopwatch-plugin
(package
(name "xfce4-stopwatch-plugin")
- (version "0.4.0")
+ (version "0.5.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/panel-plugins/"
@@ -1931,7 +1927,7 @@ freedesktop.org specification.")
"/xfce4-stopwatch-plugin-" version ".tar.bz2"))
(sha256
(base32
- "0jfr0ykn97hfngh0hd2wrs9rxswzxaxjv93g6csdp8hnij649nm3"))))
+ "1q840298jzdqlhc9lw49q32xzdhnbzcgvv69qq5slkc704s5w6vw"))))
(build-system gnu-build-system)
(native-inputs
`(("intltool" ,intltool)