aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f85bca491a..9ca5b96fe8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -194,3 +194,31 @@ config files. Layouts are applied dynamically, and different layouts may be
used on each workspace. Xinerama is fully supported, allowing windows to be
tiled on several screens.")
(license bsd-3)))
+
+(define-public ghc-xmonad-contrib
+ (package
+ (name "ghc-xmonad-contrib")
+ (version "0.11.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/xmonad-contrib/"
+ "xmonad-contrib-" version ".tar.gz"))
+ (sha256
+ (base32
+ "14h9vr33yljymswj50wbimav263y9abdcgi07mvfis0zd08rxqxa"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("ghc-random" ,ghc-random)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+ ("ghc-x11" ,ghc-x11)
+ ("ghc-x11-xft" ,ghc-x11-xft)
+ ("xmonad" ,xmonad)))
+ (home-page "http://xmonad.org")
+ (synopsis "Third party extensions for xmonad")
+ (description
+ "Third party tiling algorithms, configurations, and scripts to Xmonad, a
+tiling window manager for X.")
+ (license bsd-3)))