aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5dc0b4dea4..50a837f51b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7957,7 +7957,17 @@ It contains the code shared by all Kiwix ports.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "kiwix-desktop.pro"
(("webenginewidgets" all) (string-append all " printsupport")))
- #t)))))
+ #t))
+ (add-after 'install 'wrap-qt-process-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/kiwix-desktop"))
+ (qt-process-path (string-append
+ (assoc-ref inputs "qtwebengine")
+ "/lib/qt5/libexec/QtWebEngineProcess")))
+ (wrap-program bin
+ `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
+ #t))))))
(inputs
`(("curl" ,curl)
("icu4c" ,icu4c)