aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm66
1 files changed, 34 insertions, 32 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 93399b3459..edb7bd5da1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -129,6 +129,7 @@
#:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages lsof)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages mail)
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
#:use-module (gnu packages ncurses)
@@ -567,7 +568,7 @@ documentation.")
(package
(inherit nginx)
(name "nginx-lua-module")
- (version "0.10.15")
+ (version "0.10.16")
(source
(origin
(method git-fetch)
@@ -576,8 +577,7 @@ documentation.")
(commit (string-append "v" version))))
(file-name (git-file-name "lua-nginx-module" version))
(sha256
- (base32
- "1j216isp0546hycklbr5wi8mlga5hq170hk7f2sm16sfavlkh5gz"))))
+ (base32 "0nwcbqm1visg1dkxav7qa16w0d0n8cgqn4881xiqn88xfkxj0dyg"))))
(build-system gnu-build-system)
(inputs
`(("nginx-sources" ,(package-source nginx-socket-cloexec))
@@ -1424,7 +1424,7 @@ used to validate and fix HTML data.")
(define-public esbuild
(package
(name "esbuild")
- (version "0.8.0")
+ (version "0.8.7")
(source
(origin
(method git-fetch)
@@ -1434,7 +1434,7 @@ used to validate and fix HTML data.")
(file-name (git-file-name name version))
(sha256
(base32
- "17qzmadjixjivwbxbj20683j3n6igk7bx7v4k5bs2rqfvigdx2ps"))
+ "14x95dmh4jrfp93p7ln0cv917qxll04sqzlpf9rl6w01fifr2s75"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3789,15 +3789,14 @@ exists it is used instead.")
(define-public perl-lwp-protocol-https
(package
(name "perl-lwp-protocol-https")
- (version "6.07")
+ (version "6.09")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/O/OA/OALDERS/"
"LWP-Protocol-https-" version ".tar.gz"))
(sha256
- (base32
- "1rxrpwylfw1afah0nk96kgkwjbl2p1a7lwx50iipg8c4rx3cjb2j"))))
+ (base32 "14pm785cgyrnppks6ccasb2vkqifh0a8fz36nmnhc2v926jy3kqn"))))
(build-system perl-build-system)
(native-inputs
;; For tests.
@@ -4423,14 +4422,14 @@ RFC 6570.")
(uri (string-append
"mirror://cpan/authors/id/S/SZ/SZBALINT/WWW-Curl-"
version".tar.gz"))
- (patches (search-patches "perl-www-curl-remove-symbol.patch"))
+ (patches (search-patches "perl-www-curl-fix-struct-void.patch"
+ "perl-www-curl-remove-symbol.patch"))
(sha256
(base32
"1fmp9aib1kaps9vhs4dwxn7b15kgnlz9f714bxvqsd1j1q8spzsj"))))
(build-system perl-build-system)
(arguments
'(#:tests? #f ;XXX: tests require network access
-
#:phases (modify-phases %standard-phases
(add-before 'configure 'set-search-path
(lambda _
@@ -5630,14 +5629,14 @@ on the fly.")
(define-public hitch
(package
(name "hitch")
- (version "1.6.0")
+ (version "1.7.0")
(home-page "https://hitch-tls.org/")
(source (origin
(method url-fetch)
(uri (string-append home-page "source/hitch-" version ".tar.gz"))
(sha256
(base32
- "01n70yf8hx42jb801jv5q1xhrpqxyjnqhd98hjf81lvxpd5fnisf"))))
+ "1i75giwyr66ip8xsvk3gg5xdbxnmcabgxz8dqi06c58mw7qzhzn9"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -5770,13 +5769,13 @@ deployments.")
(package
(name "varnish")
(home-page "https://varnish-cache.org/")
- (version "6.4.0")
+ (version "6.5.1")
(source (origin
(method url-fetch)
(uri (string-append home-page "_downloads/varnish-" version ".tgz"))
(sha256
(base32
- "1hkn98vbxk7rc1sd08367qn6rcv8wkxgwbmm1x46y50vi0nvldpn"))))
+ "1dfdswri6lkfk6kml3szvffm91y49pajgqy1k5y26llqixl4r5hi"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib")
@@ -5844,18 +5843,25 @@ configuration language.")
(package
(name "varnish-modules")
(home-page "https://github.com/varnish/varnish-modules")
- (version "0.16.0")
+ (version "0.17.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/varnish/varnish-modules"
- "/releases/download/varnish-modules-" version
- "/varnish-modules-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1ph5bplsip4rycql1c2hgbvmrwbgcrgv2ldgfp7saxxbsv5cpcds"))))
+ "0zg8y2sgkygdani70zp9rbx278431fmssj26d47c5qsiw939i519"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+
+ ;; For bootstrapping.
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+
+ ;; For generating manuals.
+ ("rst2man" ,python-docutils)))
(inputs
`(("python" ,python)
("varnish" ,varnish)))
@@ -7706,10 +7712,11 @@ solution for any project's interface needs:
(license license:expat)))
(define-public gmnisrv
- (let ((commit "a22bec51494a50c044416d469cc33e043480e7fd"))
+ (let ((commit "d484ba0ab0020866535a44be5948c9482b8f2b8d")
+ (revision "1"))
(package
(name "gmnisrv")
- (version (git-version "0" "0" commit))
+ (version (git-version "0" revision commit))
(home-page "https://git.sr.ht/~sircmpwn/gmnisrv")
(source (origin
(method git-fetch)
@@ -7718,7 +7725,7 @@ solution for any project's interface needs:
(commit commit)))
(sha256
(base32
- "1k1n7cqd37jgbhxyh231bagdxdxqwpr6n5pk3gax2516w6xbzlb9"))
+ "11phipixsxx1jgm42agp76p5s68l0zj65kgb41vzaymgwcq79ivn"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -7728,19 +7735,14 @@ solution for any project's interface needs:
(lambda _
(setenv "CC" "gcc")
#t))
- (delete 'check)
- (add-after 'install 'install-config
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((etc (string-append (assoc-ref outputs "out")
- "/etc")))
- (mkdir-p etc)
- (copy-file "config.ini" (string-append etc "/gmnisrv.ini"))
- #t))))))
+ (delete 'check))))
(inputs
`(("openssl" ,openssl)))
(native-inputs
`(("pkg-config" ,pkg-config)
("scdoc" ,scdoc)))
+ (propagated-inputs
+ `(("mailcap" ,mailcap)))
(synopsis "Simple Gemini protocol server")
(description "gmnisrv is a simple Gemini protocol server written in C.")
(license (list license:gpl3+