aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 85bbe7e9c6..1edd1ac56a 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -48,27 +48,17 @@
(define-public gvpe
(package
(name "gvpe")
- (version "3.0")
+ (version "3.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gvpe/gvpe-"
version ".tar.gz"))
(sha256
(base32
- "1v61mj25iyd91z0ir7cmradkkcm1ffbk52c96v293ibsvjs2s2hf"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove the outdated bundled copy of glibc's getopt, which
- ;; provides a 'getopt' declaration that conflicts with that
- ;; of glibc 2.26.
- (substitute* "lib/Makefile.in"
- (("getopt1?\\.(c|h|\\$\\(OBJEXT\\))") ""))
- (for-each delete-file
- '("lib/getopt.h" "lib/getopt.c"))
- #t))))
+ "1cz8n75ksl0l908zc5l3rnfm1hv7130s2w8710799fr5sxrdbszi"))))
(build-system gnu-build-system)
(home-page "http://software.schmorp.de/pkg/gvpe.html")
+ (native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("openssl" ,openssl)
("zlib" ,zlib)))
(synopsis "Secure VPN among multiple nodes over an untrusted network")
@@ -312,14 +302,14 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
(define-public tinc
(package
(name "tinc")
- (version "1.0.33")
+ (version "1.0.35")
(source (origin
(method url-fetch)
- (uri (string-append "http://tinc-vpn.org/packages/"
+ (uri (string-append "https://tinc-vpn.org/packages/"
name "-" version ".tar.gz"))
(sha256
(base32
- "1x0hpfz13vn4pl6dcpnls6xq3rfcbdsg90awcfn53ijb8k35svvz"))))
+ "0pl92sdwrkiwgll78x0ww06hfljd07mkwm62g8x17qn3gha3pj0q"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -328,7 +318,7 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
(inputs `(("zlib" ,zlib)
("lzo" ,lzo)
("openssl" ,openssl)))
- (home-page "http://tinc-vpn.org")
+ (home-page "https://tinc-vpn.org")
(synopsis "Virtual Private Network (VPN) daemon")
(description
"Tinc is a VPN that uses tunnelling and encryption to create a secure
@@ -347,6 +337,16 @@ private network between hosts on the internet.")
(base32
"0pqk43kd7crqhg6qgnl8kapncwgw1xgaf02zarzypcw64kvdih9h"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-FHS-file-names
+ (lambda _
+ (substitute* "sshuttle/client.py"
+ (("/usr/bin/env") (which "env")))
+ (substitute* "sshuttle/ssh.py"
+ (("/bin/sh") "sh"))
+ #t)))))
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)
;; For tests only.