aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/virtualization.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/virtualization.scm')
-rw-r--r--gnu/packages/virtualization.scm41
1 files changed, 6 insertions, 35 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 34270ff8d3..9bd8ebbe18 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -142,7 +142,7 @@
(define-public qemu
(package
(name "qemu")
- (version "5.2.0")
+ (version "6.0.0")
(source
(origin
(method url-fetch)
@@ -150,24 +150,14 @@
version ".tar.xz"))
(sha256
(base32
- "1g0pvx4qbirpcn9mni704y03n3lvkmw2c0rbcwvydyr8ns4xh66b"))
+ "1f9hz8rf12jm8baa7kda34yl4hyl0xh0c4ap03krfjx23i3img47"))
(patches (search-patches "qemu-CVE-2021-20203.patch"
+ "qemu-meson-compat.patch"
+ "qemu-sphinx-compat.patch"
"qemu-build-info-manual.patch"))
(modules '((guix build utils)))
(snippet
'(begin
- ;; Fix a bug in the do_ioctl_ifconf() function of qemu to
- ;; make ioctl(…, SIOCGIFCONF, …) work for emulated 64 bit
- ;; architectures. The size of struct ifreq is handled
- ;; incorrectly.
- ;; https://lists.nongnu.org/archive/html/qemu-devel/2021-01/msg01545.html
- (substitute* '("linux-user/syscall.c")
- (("^([[:blank:]]*)const argtype ifreq_arg_type.*$" line indent)
- (string-append line indent "const argtype ifreq_max_type[] = "
- "{ MK_STRUCT(STRUCT_ifmap_ifreq) };\n"))
- (("^([[:blank:]]*)target_ifreq_size[[:blank:]]=.*$" _ indent)
- (string-append indent "target_ifreq_size = "
- "thunk_type_size(ifreq_max_type, 0);")))
;; Delete the bundled meson copy.
(delete-file-recursively "meson")))))
(outputs '("out" "static" "doc")) ;5.3 MiB of HTML docs
@@ -198,22 +188,6 @@
,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
- (add-after 'set-paths 'hide-glibc
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Work around https://issues.guix.info/issue/36882. We need to
- ;; remove glibc from C_INCLUDE_PATH so that the one hardcoded in GCC,
- ;; at the bottom of GCC include search-path is used.
- (let* ((filters '("libc"))
- (input-directories
- (filter-map (lambda (input)
- (match input
- ((name . dir)
- (and (not (member name filters))
- dir))))
- inputs)))
- (set-path-environment-variable "C_INCLUDE_PATH"
- '("include")
- input-directories))))
(add-after 'unpack 'extend-test-time-outs
(lambda _
;; These tests can time out on heavily-loaded and/or slow storage.
@@ -223,14 +197,14 @@
(string-append match "9")))))
(add-after 'unpack 'disable-unusable-tests
(lambda _
- (substitute* "tests/meson.build"
+ (substitute* "tests/unit/meson.build"
;; Comment out the test-qga test, which needs /sys and
;; fails within the build environment.
(("tests.*test-qga.*$" all)
(string-append "# " all))
;; Comment out the test-char test, which needs networking and
;; fails within the build environment.
- (("check-unit-.* tests/test-char" all)
+ ((".*'test-char':.*" all)
(string-append "# " all)))))
(add-after 'patch-source-shebangs 'patch-embedded-shebangs
(lambda _
@@ -1223,9 +1197,6 @@ three libraries:
virtualization library.")
(license license:lgpl2.1+)))
-(define-public python2-libvirt
- (package-with-python2 python-libvirt))
-
(define-public virt-manager
(package
(name "virt-manager")