aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 0ba2f4e7ef..ecce4e0ae6 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -459,7 +459,7 @@ trouble using them, because you do not have to remember each snippet name.")
(define-public vim-fugitive
(package
(name "vim-fugitive")
- (version "2.3")
+ (version "2.5")
(source
(origin
(method git-fetch)
@@ -469,7 +469,7 @@ trouble using them, because you do not have to remember each snippet name.")
(file-name (git-file-name name version))
(sha256
(base32
- "17s94a8g5z0lrs7yy4nyqyvp9ykys5ws2ar3m3c0bjsn0iazd7m3"))))
+ "17yz7gxn7a49jzndr4z5vnk1y4a6c22qss3mwxzmq4m46fni0k8q"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f
@@ -481,9 +481,13 @@ trouble using them, because you do not have to remember each snippet name.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(vimfiles (string-append out "/share/vim/vimfiles"))
+ (autoload (string-append vimfiles "/autoload"))
(doc (string-append vimfiles "/doc"))
+ (ftdetect (string-append vimfiles "/ftdetect"))
(plugin (string-append vimfiles "/plugin")))
+ (copy-recursively "autoload" autoload)
(copy-recursively "doc" doc)
+ (copy-recursively "ftdetect" ftdetect)
(copy-recursively "plugin" plugin)
#t))))))
(home-page "https://github.com/tpope/vim-fugitive")
@@ -652,7 +656,7 @@ are detected, the user is notified.")))
(define-public neovim
(package
(name "neovim")
- (version "0.2.0")
+ (version "0.3.1")
(source
(origin
(method url-fetch)
@@ -661,12 +665,13 @@ are detected, the user is notified.")))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1db27zm6cldm1aw0570vii1bxc16a34x8lissl1h9rizsbwn7qkj"))))
+ "08mdffcw4k503bccm1plq8r7hjx4w61w5jyfdj80fr079hnkjpmw"))))
(build-system cmake-build-system)
(arguments
`(#:modules ((srfi srfi-26)
(guix build cmake-build-system)
(guix build utils))
+ #:configure-flags '("-DPREFER_LUA:BOOL=YES")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-lua-paths