aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm137
1 files changed, 74 insertions, 63 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8ded42ce96..e5e4743b2c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -97,7 +97,7 @@
(arguments
'(#:phases
(modify-phases %standard-phases
- (replace configure
+ (replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
;; This old `configure' script doesn't support
;; variables passed as arguments.
@@ -320,11 +320,11 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
(guix build utils)
(guix build rpath)
(srfi srfi-26))
- #:imported-modules ((guix build gnu-build-system)
- (guix build utils)
+ #:imported-modules (,@%gnu-build-system-modules
(guix build rpath))
#:phases
- (alist-replace
+ (modify-phases %standard-phases
+ (replace
'configure
;; configure does not work followed by "SHELL=..." and
;; "CONFIG_SHELL=..."; set environment variables instead
@@ -334,48 +334,48 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
(("#! /bin/sh") (string-append "#!" (which "bash"))))
(setenv "SHELL" (which "bash"))
(setenv "CONFIG_SHELL" (which "bash"))
- ;; FIXME: only needed for ffmpeg-2.2.13, but easier to add
- ;; globally; drop as soon as ffmpeg-2.2.13 is dropped
+ ;; FIXME: only needed for ffmpeg-2.2.13, but easier to add
+ ;; globally; drop as soon as ffmpeg-2.2.13 is dropped
(setenv "LDFLAGS" "-ldl")
-;; possible additional inputs:
-;; --enable-avisynth enable reading of AviSynth script files [no]
-;; --enable-frei0r enable frei0r video filtering
-;; --enable-libaacplus enable AAC+ encoding via libaacplus [no]
-;; --enable-libcelt enable CELT decoding via libcelt [no]
-;; --enable-libdc1394 enable IIDC-1394 grabbing using libdc1394
-;; and libraw1394 [no]
-;; --enable-libfaac enable AAC encoding via libfaac [no]
-;; --enable-libfdk-aac enable AAC de/encoding via libfdk-aac [no]
-;; --enable-libflite enable flite (voice synthesis) support via libflite [no]
-;; --enable-libgme enable Game Music Emu via libgme [no]
-;; --enable-libgsm enable GSM de/encoding via libgsm [no]
-;; --enable-libiec61883 enable iec61883 via libiec61883 [no]
-;; --enable-libilbc enable iLBC de/encoding via libilbc [no]
-;; --enable-libmodplug enable ModPlug via libmodplug [no]
-;; --enable-libnut enable NUT (de)muxing via libnut,
-;; native (de)muxer exists [no]
-;; --enable-libopencore-amrnb enable AMR-NB de/encoding via libopencore-amrnb [no]
-;; --enable-libopencore-amrwb enable AMR-WB decoding via libopencore-amrwb [no]
-;; --enable-libopencv enable video filtering via libopencv [no]
-;; --enable-libopenjpeg enable JPEG 2000 de/encoding via OpenJPEG [no]
-;; --enable-librtmp enable RTMP[E] support via librtmp [no]
-;; --enable-libschroedinger enable Dirac de/encoding via libschroedinger [no]
-;; --enable-libshine enable fixed-point MP3 encoding via libshine [no]
-;; --enable-libssh enable SFTP protocol via libssh [no]
-;; (libssh2 does not work)
-;; --enable-libstagefright-h264 enable H.264 decoding via libstagefright [no]
-;; --enable-libutvideo enable Ut Video encoding and decoding via libutvideo [no]
-;; --enable-libv4l2 enable libv4l2/v4l-utils [no]
-;; --enable-libvidstab enable video stabilization using vid.stab [no]
-;; --enable-libvo-aacenc enable AAC encoding via libvo-aacenc [no]
-;; --enable-libvo-amrwbenc enable AMR-WB encoding via libvo-amrwbenc [no]
-;; --enable-libwavpack enable wavpack encoding via libwavpack [no]
-;; --enable-libx264 enable H.264 encoding via x264 [no]
-;; --enable-libxavs enable AVS encoding via xavs [no]
-;; --enable-libzmq enable message passing via libzmq [no]
-;; --enable-libzvbi enable teletext support via libzvbi [no]
-;; --enable-opencl enable OpenCL code
-;; --enable-x11grab enable X11 grabbing [no]
+ ;; possible additional inputs:
+ ;; --enable-avisynth enable reading of AviSynth script files [no]
+ ;; --enable-frei0r enable frei0r video filtering
+ ;; --enable-libaacplus enable AAC+ encoding via libaacplus [no]
+ ;; --enable-libcelt enable CELT decoding via libcelt [no]
+ ;; --enable-libdc1394 enable IIDC-1394 grabbing using libdc1394
+ ;; and libraw1394 [no]
+ ;; --enable-libfaac enable AAC encoding via libfaac [no]
+ ;; --enable-libfdk-aac enable AAC de/encoding via libfdk-aac [no]
+ ;; --enable-libflite enable flite (voice synthesis) support via libflite [no]
+ ;; --enable-libgme enable Game Music Emu via libgme [no]
+ ;; --enable-libgsm enable GSM de/encoding via libgsm [no]
+ ;; --enable-libiec61883 enable iec61883 via libiec61883 [no]
+ ;; --enable-libilbc enable iLBC de/encoding via libilbc [no]
+ ;; --enable-libmodplug enable ModPlug via libmodplug [no]
+ ;; --enable-libnut enable NUT (de)muxing via libnut,
+ ;; native (de)muxer exists [no]
+ ;; --enable-libopencore-amrnb enable AMR-NB de/encoding via libopencore-amrnb [no]
+ ;; --enable-libopencore-amrwb enable AMR-WB decoding via libopencore-amrwb [no]
+ ;; --enable-libopencv enable video filtering via libopencv [no]
+ ;; --enable-libopenjpeg enable JPEG 2000 de/encoding via OpenJPEG [no]
+ ;; --enable-librtmp enable RTMP[E] support via librtmp [no]
+ ;; --enable-libschroedinger enable Dirac de/encoding via libschroedinger [no]
+ ;; --enable-libshine enable fixed-point MP3 encoding via libshine [no]
+ ;; --enable-libssh enable SFTP protocol via libssh [no]
+ ;; (libssh2 does not work)
+ ;; --enable-libstagefright-h264 enable H.264 decoding via libstagefright [no]
+ ;; --enable-libutvideo enable Ut Video encoding and decoding via libutvideo [no]
+ ;; --enable-libv4l2 enable libv4l2/v4l-utils [no]
+ ;; --enable-libvidstab enable video stabilization using vid.stab [no]
+ ;; --enable-libvo-aacenc enable AAC encoding via libvo-aacenc [no]
+ ;; --enable-libvo-amrwbenc enable AMR-WB encoding via libvo-amrwbenc [no]
+ ;; --enable-libwavpack enable wavpack encoding via libwavpack [no]
+ ;; --enable-libx264 enable H.264 encoding via x264 [no]
+ ;; --enable-libxavs enable AVS encoding via xavs [no]
+ ;; --enable-libzmq enable message passing via libzmq [no]
+ ;; --enable-libzvbi enable teletext support via libzvbi [no]
+ ;; --enable-opencl enable OpenCL code
+ ;; --enable-x11grab enable X11 grabbing [no]
(zero? (system*
"./configure"
(string-append "--prefix=" out)
@@ -410,18 +410,27 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
"--disable-mips32r2"
"--disable-mipsdspr1"
"--disable-mipsdspr2"
- "--disable-mipsfpu"))))
- (alist-cons-after
- 'strip 'add-lib-to-runpath
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib")))
- ;; Add LIB to the RUNPATH of all the executables and libraries.
- (with-directory-excursion out
- (for-each (cut augment-rpath <> lib)
- (append (find-files "bin" ".*")
- (find-files "lib" "\\.so\\..*\\."))))))
- %standard-phases))))
+ "--disable-mipsfpu")))))
+ (add-before
+ 'check 'set-ld-library-path
+ (lambda _
+ ;; Allow $(top_builddir)/ffmpeg to find its dependencies when
+ ;; running tests.
+ (let* ((dso (find-files "." "\\.so$"))
+ (path (string-join (map dirname dso) ":")))
+ (format #t "setting LD_LIBRARY_PATH to ~s~%" path)
+ (setenv "LD_LIBRARY_PATH" path)
+ #t)))
+ (add-after
+ 'strip 'add-lib-to-runpath
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib")))
+ ;; Add LIB to the RUNPATH of all the executables and libraries.
+ (with-directory-excursion out
+ (for-each (cut augment-rpath <> lib)
+ (append (find-files "bin" ".*")
+ (find-files "lib" "\\.so\\..*\\."))))))))))
(home-page "http://www.ffmpeg.org/")
(synopsis "Audio and video framework")
(description "FFmpeg is a complete, cross-platform solution to record,
@@ -444,7 +453,7 @@ audio/video codec library.")
(define-public vlc
(package
(name "vlc")
- (version "2.1.5")
+ (version "2.2.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -452,7 +461,7 @@ audio/video codec library.")
version "/vlc-" version ".tar.xz"))
(sha256
(base32
- "0whzbn7ahn5maarcwl1yhk9lq10b0q0y9w5pjl9kh3frdjmncrbg"))))
+ "05smn9hqdp7iscc1dj4cxp1mrlad7b50lhlnlqisfzf493i2f2jy"))))
(build-system gnu-build-system)
(native-inputs
`(("git" ,git) ; needed for a test
@@ -463,7 +472,7 @@ audio/video codec library.")
("avahi" ,avahi)
("dbus" ,dbus)
("flac" ,flac)
- ("ffmpeg" ,ffmpeg-2.2) ; FIXME: vlc-2.1.5 won't work with ffmpeg-2.4
+ ("ffmpeg" ,ffmpeg)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
("gnutls" ,gnutls)
@@ -775,12 +784,12 @@ several areas.")
'(#:phases
(modify-phases %standard-phases
(add-before
- configure setup-waf
+ 'configure 'setup-waf
(lambda* (#:key inputs #:allow-other-keys)
(copy-file (assoc-ref inputs "waf") "waf")
(setenv "CC" "gcc")))
(add-before
- configure patch-wscript
+ 'configure 'patch-wscript
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "wscript"
;; XXX Remove this when our Samba package provides a .pc file.
@@ -820,6 +829,8 @@ projects while introducing many more.")
(lambda* (#:key outputs #:allow-other-keys)
(setenv "CONFIG_SHELL" (which "bash"))
(let ((out (assoc-ref outputs "out")))
+ (setenv "LDFLAGS"
+ (string-append "-Wl,-rpath=" out "/lib"))
(zero? (system* "./configure"
"--enable-shared"
"--as=yasm"
@@ -1256,7 +1267,7 @@ capabilities.")
'(#:phases
(modify-phases %standard-phases
(add-after
- unpack autogen
+ 'unpack 'autogen
(lambda _
(zero? (system* "sh" "autogen.sh")))))))
(home-page "http://www.vapoursynth.com/")