aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4eb6b8b6e8..3924e93f96 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2253,9 +2253,9 @@ practically any type of media.")
(add-before 'configure 'pre-configure
(lambda _
(chdir "Project/GNU/Library")))
- (add-before 'configure 'autogen
+ (add-after 'unpack 'autogen
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh")))))))
(home-page "https://mediaarea.net/en/MediaInfo")
(synopsis "Library for retrieving media metadata")
(description "MediaInfo is a library used for retrieving technical
@@ -2311,9 +2311,9 @@ MPEG-2, MPEG-4, DVD (VOB)...
(add-before 'configure 'pre-configure
(lambda _
(chdir "Project/GNU/CLI")))
- (add-before 'configure 'autogen
+ (add-after 'unpack 'autogen
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh")))))))
(home-page "https://mediaarea.net/en/MediaInfo")
(synopsis "Utility for reading media metadata")
(description "MediaInfo is a utility used for retrieving technical