aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ca6148b078..6a14a85b74 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5285,6 +5285,12 @@ result in several formats:
(substitute* "Cargo.toml"
;; Allow using more recent versions of
(("~3.1.2") "~3"))))
+ (add-after 'configure 'force-rust-edition-2018
+ (lambda* (#:key vendor-dir #:allow-other-keys)
+ ;; Force all the dependencies to not be higher than edition 2018.
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* (find-files vendor-dir "Cargo.toml")
+ (("edition = \\\"2021\\\"") "edition = \"2018\"")))))
(replace 'build
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))