aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm30
1 files changed, 22 insertions, 8 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 20db6b4b08..2ca64e4cdc 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -594,7 +595,7 @@ write native speed custom Git applications in any language with bindings.")
(define-public git-crypt
(package
(name "git-crypt")
- (version "0.5.0")
+ (version "0.6.0")
(source
(origin
(method git-fetch)
@@ -603,25 +604,38 @@ write native speed custom Git applications in any language with bindings.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1x9209n3k49k998saadr2d0lmvs01smjinx7gzzyjdwj9l904sii"))))
+ (base32 "1ba5s0fvmd9hhnfhfsjrm40v0qpxfnwc8vmm55m0k4dryzkzx66q"))))
(build-system gnu-build-system)
(inputs
`(("git" ,git)
("openssl" ,openssl)))
+ (native-inputs
+ `(("docbook-xsl" ,docbook-xsl)
+ ("libxslt" ,libxslt)))
(arguments
`(#:tests? #f ; No tests.
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (add-after 'unpack 'patch-makefile
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/manpages/docbook.xsl")))
+ #t))
(replace 'build
(lambda _
- (invoke "make")))
+ (invoke "make" "ENABLE_MAN=yes")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(invoke "make" "install"
+ "ENABLE_MAN=yes"
(string-append "PREFIX=" out))))))))
- (home-page "https://www.agwa.name/projects/git-crypt")
+ (home-page "https://www.agwa.name/projects/git-crypt/")
(synopsis "Transparent encryption of files in a git repository")
(description "git-crypt enables transparent encryption and decryption of
files in a git repository. Files which you choose to protect are encrypted when
@@ -1007,16 +1021,16 @@ will work.")
(name "git-flow")
;; This version has not be officially released yet, so we build it
;; directly from the git repository.
- (version "0.4.2-pre")
+ (version "1.12.3")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/nvie/gitflow/")
- (commit "15aab26490facf285acef56cb5d61025eacb3a69")))
+ (url "https://github.com/petervanderdoes/gitflow-avh/")
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "01fs97q76fdfnvmrh2cyjhywcs3pykf1dg58sy0frflnsdzs6prx"))))
+ "13q4mnrxr03wz2dkhzy73j384g299m4d545cnhxcaznvdwfany4h"))))
(build-system gnu-build-system)
(inputs `(("shflags" ,shflags)))
(arguments