aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5eaaf2681e..f53ca9b11b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -6,12 +6,12 @@
;;; Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2016, 2019 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2018, 2020 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015, 2017, 2018, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
-;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017, 2020 EuAndreh <eu@euandre.org>
@@ -1683,14 +1683,14 @@ history. It implements the changeset evolution concept for Mercurial.")
(define-public neon
(package
(name "neon")
- (version "0.30.2")
+ (version "0.31.2")
(source (origin
(method url-fetch)
- (uri (string-append "http://www.webdav.org/neon/neon-"
+ (uri (string-append "https://notroj.github.io/neon/neon-"
version ".tar.gz"))
(sha256
(base32
- "1jpvczcx658vimqm7c8my2q41fnmjaf1j03g7bsli6rjxk6xh2yv"))))
+ "0y46dbhiblcvg8k41bdydr3fivghwk73z040ki5825d24ynf67ng"))))
(build-system gnu-build-system)
(native-inputs
`(("perl" ,perl)
@@ -1704,11 +1704,12 @@ history. It implements the changeset evolution concept for Mercurial.")
;; https://sourceware.org/bugzilla/show_bug.cgi?id=16475
#:tests? #f
#:configure-flags '("--enable-shared"
+ "--disable-static"
;; requires libgnutils-config, deprecated
;; in gnutls 2.8.
; "--with-ssl=gnutls")))
"--with-ssl=openssl")))
- (home-page "http://www.webdav.org/neon/")
+ (home-page "https://notroj.github.io/neon/")
(synopsis "HTTP and WebDAV client library")
(description
"Neon is an HTTP and WebDAV client library, with a C interface and the
@@ -1937,7 +1938,7 @@ standards-compliant ChangeLog entries based on the changes that it detects.")
(define-public diffstat
(package
(name "diffstat")
- (version "1.63")
+ (version "1.64")
(source (origin
(method url-fetch)
(uri
@@ -1948,7 +1949,7 @@ standards-compliant ChangeLog entries based on the changes that it detects.")
"diffstat-" version ".tgz")))
(sha256
(base32
- "0vyw200s5dv1257pmrh6c6fdkmw3slyz5szpqfx916xr04sdbpby"))))
+ "1z7pwcv48fjnhxrjcsjdy83x8b9ckl582mbbds90a79fkn6y7bmq"))))
(build-system gnu-build-system)
(home-page "https://invisible-island.net/diffstat/")
(synopsis "Make histograms from the output of @command{diff}")