aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index d8d4a77341..2238554706 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -46,6 +46,7 @@
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
+;;; Copyright © 2015, 2022 David Thompson <davet@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -139,7 +140,8 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages)
#:use-module (ice-9 match)
- #:use-module (srfi srfi-1))
+ #:use-module (srfi srfi-1)
+ #:export (make-gitolite))
(define-public breezy
(package
@@ -1484,7 +1486,9 @@ linear. It will test every change between two points in the DAG. It will
also walk each side of a merge and test those changes individually.")
(license (license:x11-style "file://LICENSE")))))
-(define-public gitolite
+(define* (make-gitolite #:optional (extra-inputs '()))
+ "Make a gitolite package object with EXTRA-INPUTS added to the binary
+wrappers, to be used for optional gitolite extensions."
(package
(name "gitolite")
(version "3.6.12")
@@ -1576,10 +1580,12 @@ also walk each side of a merge and test those changes individually.")
(list #$output
#$coreutils
#$findutils
- #$git)))))
+ #$git
+ #$@extra-inputs)))))
'("/bin/gitolite" "/bin/gitolite-shell")))))))
(inputs
- (list bash-minimal coreutils findutils git inetutils openssh perl))
+ (append (list bash-minimal coreutils findutils git inetutils openssh perl)
+ extra-inputs))
(home-page "https://gitolite.com")
(synopsis "Git access control layer")
(description
@@ -1587,6 +1593,8 @@ also walk each side of a merge and test those changes individually.")
control to Git repositories.")
(license license:gpl2)))
+(define-public gitolite (make-gitolite))
+
(define-public gitile
(package
(name "gitile")