aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 976849b184..ded181e8ab 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2018 ng0 <ng0@n0.is>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 André <eu@euandre.org>
@@ -1318,14 +1318,16 @@ any project with more than one developer, is one of Aegis's major functions.")
(define-public reposurgeon
(package
(name "reposurgeon")
- (version "3.37")
+ (version "3.43")
(source (origin
(method url-fetch)
(uri (string-append "http://www.catb.org/~esr/" name "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "14asjg4xy3mhh5z0r3k7c1wv9y803j2zfq32g5q5m95sf7yzygan"))))
+ "1af0z14wcm4bk5a9ysinbwq2fp3lf5f7i8mvwh7286hr3fnagcaz"))
+ (patches (search-patches
+ "reposurgeon-add-missing-docbook-files.patch"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;no test suite distributed
@@ -1333,6 +1335,13 @@ any project with more than one developer, is one of Aegis's major functions.")
(list (string-append "target=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-inputs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((tzdata (assoc-ref inputs "tzdata")))
+ (substitute* "reposurgeon"
+ (("/usr/share/zoneinfo")
+ (string-append tzdata "/share/zoneinfo")))
+ #t)))
(delete 'configure)
(add-before 'build 'fix-docbook
(lambda* (#:key inputs #:allow-other-keys)
@@ -1347,10 +1356,11 @@ any project with more than one developer, is one of Aegis's major functions.")
(string-append (assoc-ref outputs "out")
"/share/emacs/site-lisp")))))))
(inputs
- `(("python" ,python-wrapper)))
+ `(("python" ,python-wrapper)
+ ("tzdata" ,tzdata)))
(native-inputs
`(("asciidoc" ,asciidoc)
- ("docbook-xml" ,docbook-xml-4.1.2)
+ ("docbook-xml" ,docbook-xml)
("docbook-xsl" ,docbook-xsl)
("libxml2" ,libxml2)
("xmlto" ,xmlto)))