aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 41df90b8a7..ef08bbe5e8 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -117,15 +117,13 @@ as well as the classic centralized workflow.")
"/bin/wish8.6")) ; XXX
#:phases
- (alist-replace
- 'configure
- (lambda* (#:key #:allow-other-keys #:rest args)
- (let ((configure (assoc-ref %standard-phases 'configure)))
- (and (apply configure args)
- (substitute* "Makefile"
- (("/bin/sh") (which "sh"))
- (("/usr/bin/perl") (which "perl"))
- (("/usr/bin/python") (which "python"))))))
+ (alist-cons-after
+ 'configure 'patch-makefile-shebangs
+ (lambda _
+ (substitute* "Makefile"
+ (("/bin/sh") (which "sh"))
+ (("/usr/bin/perl") (which "perl"))
+ (("/usr/bin/python") (which "python"))))
(alist-cons-after
'install 'split
(lambda* (#:key inputs outputs #:allow-other-keys)