aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm52
1 files changed, 3 insertions, 49 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index c0b92bab04..1ab909d53e 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -38,7 +38,6 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix build-system cmake)
- #:use-module (guix build-system haskell)
#:use-module (guix build-system trivial)
#:use-module (gnu packages compression)
#:use-module (gnu packages)
@@ -48,9 +47,6 @@
#:use-module (gnu packages dns)
#:use-module (gnu packages gawk)
#:use-module (gnu packages guile)
- #:use-module (gnu packages haskell)
- #:use-module (gnu packages haskell-check)
- #:use-module (gnu packages haskell-crypto)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libidn)
@@ -533,13 +529,13 @@ netcat implementation that supports TLS.")
(package
(name "python-acme")
;; Remember to update the hash of certbot when updating python-acme.
- (version "0.32.0")
+ (version "0.33.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "acme" version))
(sha256
(base32
- "1v0skyrjnbxq0lfmia5k6jy29iig4sxbi9j9q367xsw0g25wxvqf"))))
+ "0gmnbjanv8dl8035n2b30wisqn4w9rr6fxzxrbrbnhhd40pnlplx"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -590,7 +586,7 @@ netcat implementation that supports TLS.")
(uri (pypi-uri name version))
(sha256
(base32
- "1j63i0j019q0d3l5rx14fv4nxy01nplhk7q2k2fq10vxl0jlxff0"))))
+ "0iiqr306zy56y8wpxsvzw1izs184pzps72kxhssmznqlgz5ngni5"))))
(build-system python-build-system)
(arguments
`(,@(substitute-keyword-arguments (package-arguments python-acme)
@@ -882,48 +878,6 @@ coding footprint.")
#t)))
,@(package-arguments mbedtls-apache)))))))
-(define-public ghc-tls
- (package
- (name "ghc-tls")
- (version "1.4.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/"
- "tls/tls-" version ".tar.gz"))
- (sha256
- (base32
- "1y083724mym28n6xfaz7pcc7zqxdhjpaxpbvzxfbs25qq2px3smv"))))
- (build-system haskell-build-system)
- (inputs
- `(("ghc-cereal" ,ghc-cereal)
- ("ghc-data-default-class" ,ghc-data-default-class)
- ("ghc-memory" ,ghc-memory)
- ("ghc-cryptonite" ,ghc-cryptonite)
- ("ghc-asn1-types" ,ghc-asn1-types)
- ("ghc-asn1-encoding" ,ghc-asn1-encoding)
- ("ghc-x509" ,ghc-x509)
- ("ghc-x509-store" ,ghc-x509-store)
- ("ghc-x509-validation" ,ghc-x509-validation)
- ("ghc-async" ,ghc-async)
- ("ghc-network" ,ghc-network)
- ("ghc-hourglass" ,ghc-hourglass)))
- (native-inputs
- `(("ghc-tasty" ,ghc-tasty)
- ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
- ("ghc-quickcheck" ,ghc-quickcheck)))
- (home-page "https://github.com/vincenthz/hs-tls")
- (synopsis
- "TLS/SSL protocol native implementation (Server and Client)")
- (description
- "Native Haskell TLS and SSL protocol implementation for server and client.
-This provides a high-level implementation of a sensitive security protocol,
-eliminating a common set of security issues through the use of the advanced
-type system, high level constructions and common Haskell features. Currently
-implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol, and support RSA and
-Ephemeral (Elliptic curve and regular) Diffie Hellman key exchanges, and many
-extensions.")
- (license license:bsd-3)))
-
(define-public dehydrated
(package
(name "dehydrated")