aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm41
1 files changed, 16 insertions, 25 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index fef315c5b9..7f2153f784 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016, 2017, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -244,7 +245,6 @@ cards.")
(guix build utils)
((guix build gnu-build-system) #:prefix gnu:))
#:vendor-dir "vendor"
- #:rust ,rust-1.51 ; or newer
#:install-source? #f
#:cargo-inputs
(("rust-backtrace" ,rust-backtrace-0.3)
@@ -274,29 +274,21 @@ cards.")
(lambda* (#:key vendor-dir #:allow-other-keys)
;; Don't keep the whole tarball in the vendor directory
(delete-file-recursively
- (string-append vendor-dir "/" ,name "-" ,version ".tar.xz"))
- #t))
+ (string-append vendor-dir "/" ,name "-" ,version ".tar.xz"))))
(add-after 'unpack 'patch-source
- (lambda _
+ (lambda* (#:key outputs #:allow-other-keys)
(substitute* "Makefile"
- (("Cargo.lock") ""))
- #t))
+ (("Cargo.lock") "")
+ ;; Replace the prefix in the Makefile.
+ (("/usr/local") (assoc-ref outputs "out")))))
(replace 'build
- (lambda* args
- ((assoc-ref gnu:%standard-phases 'build)
- #:make-flags
- (list (string-append "prefix=" (assoc-ref %outputs "out"))))))
+ (assoc-ref gnu:%standard-phases 'build))
(replace 'check
- (lambda* args
+ (lambda args
((assoc-ref gnu:%standard-phases 'check)
- #:test-target "test"
- #:make-flags
- (list (string-append "prefix=" (assoc-ref %outputs "out"))))))
+ #:test-target "test")))
(replace 'install
- (lambda* args
- ((assoc-ref gnu:%standard-phases 'install)
- #:make-flags
- (list (string-append "prefix=" (assoc-ref %outputs "out")))))))))
+ (assoc-ref gnu:%standard-phases 'install)))))
(native-search-paths
;; Newsboat respects CURL_CA_BUNDLE.
(package-native-search-paths curl))
@@ -373,10 +365,10 @@ file system, and many more features.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
- (python-path (getenv "PYTHONPATH")))
+ (python-path (getenv "GUIX_PYTHONPATH")))
(wrap-program (string-append out "/bin/liferea")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
- `("PYTHONPATH" ":" prefix (,python-path))))
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path))))
#t)))))
(native-inputs
`(("autoconf" ,autoconf)
@@ -432,9 +424,8 @@ a simple interface that makes it easy to organize and browse feeds.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "HOME" (getcwd))
(setenv "TERM" "linux")
- (setenv "TERMINFO" (string-append (assoc-ref inputs "ncurses")
- "/share/terminfo"))
- #t)))
+ (setenv "TERMINFO"
+ (search-input-directory inputs "share/terminfo")))))
#:tests? #f)) ; tests fail: _curses.error: nocbreak() returned ERR
(propagated-inputs
`(("python-beautifulsoup4" ,python-beautifulsoup4)
@@ -598,13 +589,13 @@ that aims to be quite fast and comfortable to its user.")
(add-after 'unpack 'patch-mpv-path
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "gfeeds/confManager.py"
- (("mpv") (string-append (assoc-ref inputs "mpv") "/bin/mpv")))
+ (("mpv") (search-input-file inputs "/bin/mpv")))
#t))
(add-after 'install 'wrap-gfeeds
(lambda* (#:key outputs #:allow-other-keys)
(wrap-program (string-append
(assoc-ref outputs "out") "/bin/gfeeds")
- `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))
+ `("PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
`("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))
`("XDG_DATA_DIRS" ":" prefix (,(getenv "XDG_DATA_DIRS"))))
#t)))))