aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 4a8c64bde8..495445acb8 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -381,6 +381,28 @@ and Francois (2011, JSS), and the book by Eddelbuettel (2013, Springer); see
'citation(\"Rcpp\")' for details on these last two.")
(license license:gpl2+)))
+(define-public r-matrix
+ (package
+ (name "r-matrix")
+ (version "1.2-7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Matrix" version))
+ (sha256
+ (base32
+ "18x3mdq5cdhbk1lw5cj7vbr41lk8w9p4i5kzh8wslgq6p3d9ac3c"))))
+ (properties `((upstream-name . "Matrix")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice)))
+ (home-page "http://Matrix.R-forge.R-project.org/")
+ (synopsis "Sparse and dense matrix classes and methods")
+ (description
+ "This package provides classes and methods for dense and sparse matrices
+and operations on them using LAPACK and SuiteSparse.")
+ (license license:gpl2+)))
+
(define-public r-mgcv
(package
(name "r-mgcv")