aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm87
1 files changed, 51 insertions, 36 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 38d75941d6..fe8c731a1a 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -183,7 +183,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
(define r-with-tests
(package
(name "r-with-tests")
- (version "3.6.3")
+ (version "4.0.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -191,7 +191,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
version ".tar.gz"))
(sha256
(base32
- "13xaxwfbzj0bd6rn2n27z0n04lb93mcyq991w4vdbbg8v282jc49"))))
+ "0h1995smlyiyhx7gpg9paxsfqrcn6g9bbp5h9r47i6an3clv1gh6"))))
(build-system gnu-build-system)
(arguments
`(#:disallowed-references (,tzdata-for-tests)
@@ -269,6 +269,11 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
(("my \\$date = strftime \"%B %Y\", localtime" line)
(string-append line " 1"))))
#t))
+ (add-before 'build 'set-locales
+ (lambda _
+ (setlocale LC_ALL "C")
+ (setenv "LC_ALL" "C")
+ #t))
(add-before 'configure 'set-default-pager
;; Set default pager to "cat", because otherwise it is "false",
;; making "help()" print nothing at all.
@@ -322,7 +327,9 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
("perl" ,perl)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo) ; for building HTML manuals
- ("texlive" ,(texlive-union (list texlive-fonts-ec
+ ("texlive" ,(texlive-union (list texlive-ae
+ texlive-inconsolata
+ texlive-fonts-ec
texlive-amsfonts
texlive-latex-base
texlive-latex-fancyvrb
@@ -331,7 +338,8 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
texlive-latex-oberdiek
texlive-latex-tools
texlive-latex-upquote
- texlive-latex-url)))
+ texlive-latex-url
+ texlive-latex-xkeyval)))
("tzdata" ,tzdata-for-tests)
("xz" ,xz)))
(inputs
@@ -347,7 +355,7 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
("libpng" ,libpng)
("libtiff" ,libtiff)
("libxt" ,libxt)
- ("pcre" ,pcre)
+ ("pcre2" ,pcre2)
("readline" ,readline)
;; This avoids a reference to the ungraftable static bash. R uses the
;; detected shell for the "system" procedure.
@@ -399,14 +407,14 @@ available, greatly increasing its breadth and scope.")
(define-public r-boot
(package
(name "r-boot")
- (version "1.3-24")
+ (version "1.3-25")
(source
(origin
(method url-fetch)
(uri (cran-uri "boot" version))
(sha256
(base32
- "0yv0l55kjmlfdx1xhgyjdi0bskxhfal74wr5jxaib1qj99nmkm49"))))
+ "1gpvi1h3nqhnnsfy96rlhakdpj84iqqsxr29rr3261sknky3aj26"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/boot")
(synopsis "Bootstrap functions for R")
@@ -420,14 +428,14 @@ D.V. Hinkley (1997, CUP), originally written by Angelo Canty for S.")
(define-public r-mass
(package
(name "r-mass")
- (version "7.3-51.5")
+ (version "7.3-51.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "MASS" version))
(sha256
(base32
- "1k0m7pa4gb5apzrrkb5kx5d7bmkm2pl5g15vwb6j067hrqahck26"))))
+ "1viyxy22qp8abzzzlbck55b0i81rrdygim1dq2pm52s2v13mq0z2"))))
(properties `((upstream-name . "MASS")))
(build-system r-build-system)
(home-page "http://www.stats.ox.ac.uk/pub/MASS4/")
@@ -441,14 +449,14 @@ Applied Statistics with S\" (4th edition, 2002) by Venables and Ripley.")
(define-public r-class
(package
(name "r-class")
- (version "7.3-16")
+ (version "7.3-17")
(source
(origin
(method url-fetch)
(uri (cran-uri "class" version))
(sha256
(base32
- "1jpdgj0lsi60q0mqbhfw809w8d66whix27y6wpdzll6775g3j3ll"))))
+ "04qk8qia0qr8893fizmkbd5hsqn6m8383c0cyn9xnmkmvyv8a7xy"))))
(build-system r-build-system)
(propagated-inputs
`(("r-mass" ,r-mass)))
@@ -504,14 +512,14 @@ code for possible problems.")
(define-public r-foreign
(package
(name "r-foreign")
- (version "0.8-76")
+ (version "0.8-79")
(source
(origin
(method url-fetch)
(uri (cran-uri "foreign" version))
(sha256
(base32
- "1z6x2x1z12wnv0z4p74d91r5wfaq30sdz4ynwx0lncz1q45mhbh5"))))
+ "1d5rk4k3khjrir1b4ciridd6vdpcgzi35r7p7ra4ky7vbaabcdmg"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/foreign")
(synopsis "Read data stored by other statistics software")
@@ -524,14 +532,14 @@ for reading and writing some dBase files.")
(define-public r-kernsmooth
(package
(name "r-kernsmooth")
- (version "2.23-16")
+ (version "2.23-17")
(source
(origin
(method url-fetch)
(uri (cran-uri "KernSmooth" version))
(sha256
(base32
- "1acrkbdn3a74y4dndkcdl1njnpfqz7gk3bsz03g8lfj8l7z53hmq"))))
+ "11g6b0q67vasxag6v9m4px33qqxpmnx47c73yv1dninv2pz76g9b"))))
(properties `((upstream-name . "KernSmooth")))
(build-system r-build-system)
(native-inputs
@@ -635,14 +643,14 @@ distributions beyond the exponential family.")
(define-public r-nnet
(package
(name "r-nnet")
- (version "7.3-13")
+ (version "7.3-14")
(source
(origin
(method url-fetch)
(uri (cran-uri "nnet" version))
(sha256
(base32
- "1z0rj5cm4ycw1y0gd5wwwg8c2298v90iybgqdqh17967jbi2125f"))))
+ "1bzl62p5awva5kxcncs6lrdrkqp9ljd993zia731ckfpcjbrw6sx"))))
(build-system r-build-system)
(home-page "http://www.stats.ox.ac.uk/pub/MASS4/")
(synopsis "Feed-forward neural networks and multinomial log-linear models")
@@ -673,14 +681,14 @@ classification, regression and survival trees.")
(define-public r-spatial
(package
(name "r-spatial")
- (version "7.3-11")
+ (version "7.3-12")
(source
(origin
(method url-fetch)
(uri (cran-uri "spatial" version))
(sha256
(base32
- "04aw8j533sn63ybyrf4hyhrqm4058vfcb7yhjy07kq92mk94hi32"))))
+ "0qrdhzd5r78iwi46nk8jr56dzz5l5imkflxjw64d0ys0wyg06fbn"))))
(build-system r-build-system)
(home-page "http://www.stats.ox.ac.uk/pub/MASS4/")
(synopsis "Functions for kriging and point pattern analysis")
@@ -1624,14 +1632,14 @@ like tidy evaluation.")
(define-public r-tibble
(package
(name "r-tibble")
- (version "3.0.0")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "tibble" version))
(sha256
(base32
- "0s84h8ls5qwixbs1n5safr3xqmg3p0llzdrd9sp4vs2572mwzqzi"))))
+ "17m7xvn423snq9dmr0bhx42j5rbc53w1viizxx4bvq37nz7m4i8m"))))
(build-system r-build-system)
(propagated-inputs
`(("r-cli" ,r-cli)
@@ -1694,25 +1702,28 @@ database.")
(define-public r-dbplyr
(package
(name "r-dbplyr")
- (version "1.4.2")
+ (version "1.4.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "dbplyr" version))
(sha256
(base32
- "1q2dflr88s5a1amzfld3087q422vf70052qn84zyd8895kdg10xp"))))
+ "1si8sahr1kwq1xgjzi9klkahad07pyrsngy75y1f74f64907pb39"))))
(build-system r-build-system)
(propagated-inputs
`(("r-assertthat" ,r-assertthat)
("r-dbi" ,r-dbi)
("r-dplyr" ,r-dplyr)
("r-glue" ,r-glue)
+ ("r-lifecycle" ,r-lifecycle)
("r-purrr" ,r-purrr)
("r-r6" ,r-r6)
("r-rlang" ,r-rlang)
("r-tibble" ,r-tibble)
("r-tidyselect" ,r-tidyselect)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/tidyverse/dbplyr")
(synopsis "Dplyr back end for databases")
(description
@@ -1989,14 +2000,14 @@ and environmental data in the framework of Euclidean exploratory methods.")
(define-public r-xml2
(package
(name "r-xml2")
- (version "1.3.1")
+ (version "1.3.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "xml2" version))
(sha256
(base32
- "0r7rxp922785dcryghbb3wxqgdav7mafwnmxjqfx8zaj3v1q2j3z"))))
+ "1kx400v62xkd5xal7rzz7jcarz94ac8g1sh4i2dqr78qwgkzj8nz"))))
(build-system r-build-system)
(inputs
`(("libxml2" ,libxml2)
@@ -2446,14 +2457,16 @@ tools to simplify the devolpment of R packages.")
(define-public r-withr
(package
(name "r-withr")
- (version "2.1.2")
+ (version "2.2.0")
(source (origin
(method url-fetch)
(uri (cran-uri "withr" version))
(sha256
(base32
- "11j6zykklxnvp4xqsr6a2xib665i38m3khdspp887nwagmvnydj1"))))
+ "10mmfffjbnb2zq5x0kqhhb4z6va4micc6pjzvlfji34gyhffa8ac"))))
(build-system r-build-system)
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/jimhester/withr")
(synopsis "Run code with temporarily modified global state")
(description
@@ -2514,13 +2527,13 @@ disk (or a connection).")
(define-public r-plotrix
(package
(name "r-plotrix")
- (version "3.7-7")
+ (version "3.7-8")
(source (origin
(method url-fetch)
(uri (cran-uri "plotrix" version))
(sha256
(base32
- "1x92mmyfry127zzr6cmcj6kjsc4zhxrrdlr0jcxn3bb0hpdfps54"))))
+ "104llmr6dvlcnfpmd8zbdlv63k79djc4qqgadjavj4v4cmz1zkcc"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/plotrix")
(synopsis "Various plotting functions")
@@ -2575,13 +2588,13 @@ well as additional utilities such as panel and axis annotation functions.")
(define-public r-rcpparmadillo
(package
(name "r-rcpparmadillo")
- (version "0.9.860.2.0")
+ (version "0.9.870.2.0")
(source (origin
(method url-fetch)
(uri (cran-uri "RcppArmadillo" version))
(sha256
(base32
- "1rg9ak0zbv8d9cyj10jq52nrcbk1pvfz28kbkhpx79mpjhrl7pb5"))))
+ "1r7iajxvbyvslsy16rqacc95azmjciw9lvcq31xl97fl09kmsq5v"))))
(properties `((upstream-name . "RcppArmadillo")))
(build-system r-build-system)
(propagated-inputs
@@ -3743,18 +3756,20 @@ It uses and relies on grid graphics and formal (S4) classes and methods.")
(define-public r-purrr
(package
(name "r-purrr")
- (version "0.3.3")
+ (version "0.3.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "purrr" version))
(sha256
(base32
- "17lyys7dxjrwsfkq7a7hw65iy3qn3pp1sn70srdy64jf8adahc8g"))))
+ "1cj091rsjdj2xz16qhynyw72gh5cyhznifcfbrbygndfr4xwksr3"))))
(build-system r-build-system)
(propagated-inputs
`(("r-magrittr" ,r-magrittr)
("r-rlang" ,r-rlang)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/hadley/purrr")
(synopsis "Functional programming tools")
(description
@@ -4942,16 +4957,16 @@ groupings.")
(define-public r-vgam
(package
(name "r-vgam")
- (version "1.1-2")
+ (version "1.1-3")
(source
(origin
(method url-fetch)
(uri (cran-uri "VGAM" version))
(sha256
- (base32 "0kyan3a4ys2xbg9kf167cyf1gk7g963id62cjm2ij4i7y4wi61zq"))))
+ (base32 "1hwlrdx3nhdp83pvy1h23i16vbbhi4kizdhr58c8nvg7kqdzb7qc"))))
(properties `((upstream-name . "VGAM")))
(build-system r-build-system)
- (inputs
+ (native-inputs
`(("gfortran" ,gfortran)))
(home-page "https://www.stat.auckland.ac.nz/~yee/VGAM")
(synopsis "Vector generalized linear and additive models")