aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm137
1 files changed, 89 insertions, 48 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 3588cb459a..9acc16e359 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
;;; Copyright © 2022 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,6 +49,7 @@
#:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
+ #:use-module (guix build-system ruby)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
@@ -82,6 +84,7 @@
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages shells)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages ssh)
@@ -636,13 +639,13 @@ estimation) corresponding to the book: Wand, M.P. and Jones, M.C. (1995)
(define-public r-lattice
(package
(name "r-lattice")
- (version "0.20-45")
+ (version "0.21-8")
(source (origin
(method url-fetch)
(uri (cran-uri "lattice" version))
(sha256
(base32
- "1b87fmyjzbg854vpi03my1p25n3d0bchhwsdm2frblxppn98sf12"))))
+ "0af3c0mk0s3gnpmg7xmd4hjjynwv4ym3iv4grjvcmrk28abxdlwa"))))
(build-system r-build-system)
(home-page "https://lattice.r-forge.r-project.org/")
(synopsis "High-level data visualization system")
@@ -656,14 +659,14 @@ also flexible enough to handle most nonstandard requirements.")
(define-public r-matrix
(package
(name "r-matrix")
- (version "1.5-3")
+ (version "1.5-4")
(source
(origin
(method url-fetch)
(uri (cran-uri "Matrix" version))
(sha256
(base32
- "03g0zqkbaa1k52i0d0yyn7vclmg93hdqaid48sbc1ccpvi70ywjf"))))
+ "01kgnsx3m19varjfn7n0g48ml6yrwr3bnjhhd0h486ynjccvdkhm"))))
(properties `((upstream-name . "Matrix")))
(build-system r-build-system)
(propagated-inputs
@@ -1235,13 +1238,13 @@ using just two functions: melt and dcast (or acast).")
(define-public r-ggplot2
(package
(name "r-ggplot2")
- (version "3.4.1")
+ (version "3.4.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggplot2" version))
(sha256
- (base32 "113d5khg0lswrbwasavl2l5jgpcd3h519mcb5iq2cq0dz4rw66q4"))))
+ (base32 "1jl3a9z668zjb2p2c01rxpgmjs5gc9gkxn8xqi7q8vrc1akhl8vh"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli
@@ -1299,14 +1302,14 @@ agnes cluster diagrams.")
(define-public r-gdtools
(package
(name "r-gdtools")
- (version "0.3.2")
+ (version "0.3.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "gdtools" version))
(sha256
(base32
- "0dji1iyf6x9vg6gjklzkb3x9vfydfi95idkvckj6208b1rwgwsj4"))))
+ "10rlx1ciyvh0ayic03kckv360idl9s1zyc2ar5lisns786c1hnns"))))
(build-system r-build-system)
(native-inputs
(list pkg-config))
@@ -1317,7 +1320,6 @@ agnes cluster diagrams.")
r-fontquiver
r-gfonts
r-htmltools
- r-memoise
r-rcpp
r-systemfonts))
(home-page "https://cran.r-project.org/web/packages/gdtools")
@@ -1787,14 +1789,14 @@ like tidy evaluation.")
(define-public r-tibble
(package
(name "r-tibble")
- (version "3.2.0")
+ (version "3.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "tibble" version))
(sha256
(base32
- "12i9cshnj2lygadh03zjw1zn5dr13wspcrq2dprl5qrrr95z2bwg"))))
+ "0c916wl19wbhncv05hjzs2vmvvbcxlswjl6i232ygmkzal62v9v5"))))
(build-system r-build-system)
(propagated-inputs
(list r-fansi
@@ -1816,13 +1818,13 @@ and printing capabilities than traditional data frames.")
(define-public r-dplyr
(package
(name "r-dplyr")
- (version "1.1.0")
+ (version "1.1.1")
(source (origin
(method url-fetch)
(uri (cran-uri "dplyr" version))
(sha256
(base32
- "1msfp29lbddwdv8ibc2nkan0g1g4y4w5fws6802v6h6x95g57c4c"))))
+ "1xxvspk1nyns39dp2fqvxbvvnkkz4rcgmhrcrznr3h1qpayj9p6z"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli
@@ -1853,14 +1855,14 @@ database.")
(define-public r-dbplyr
(package
(name "r-dbplyr")
- (version "2.3.1")
+ (version "2.3.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "dbplyr" version))
(sha256
(base32
- "0a5cnh0fr81mak9ccqr91nsjqlxsnf6a2lmwrsgv7g1sjag0b4p1"))))
+ "1b3zf2ai4kp96wd6i4jg9b3n37bwbw7lfvxvs1i1kcn6brch1p0d"))))
(build-system r-build-system)
(propagated-inputs
(list r-blob
@@ -2649,17 +2651,17 @@ were originally a part of the r-devtools package.")
(define-public r-hms
(package
(name "r-hms")
- (version "1.1.2")
+ (version "1.1.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "hms" version))
(sha256
(base32
- "1vdx08irnh8q5232hriv47hh88hc55nbbrff7y6zbainff2akrhy"))))
+ "10h2k5j97fggq3hc0qzxv1q9821y21m326v3x99zsvpl1b3g89p6"))))
(build-system r-build-system)
(propagated-inputs
- (list r-ellipsis r-lifecycle r-pkgconfig r-rlang r-vctrs))
+ (list r-lifecycle r-pkgconfig r-rlang r-vctrs))
(home-page "https://github.com/rstats-db/hms")
(synopsis "Pretty time of day")
(description
@@ -2765,13 +2767,13 @@ well as additional utilities such as panel and axis annotation functions.")
(define-public r-rcpparmadillo
(package
(name "r-rcpparmadillo")
- (version "0.12.0.1.0")
+ (version "0.12.2.0.0")
(source (origin
(method url-fetch)
(uri (cran-uri "RcppArmadillo" version))
(sha256
(base32
- "1spvsfzkzfw4l0igj2cx9ba3l2hwzqj180vndn4imdy0g4xibikk"))))
+ "1dvq5ng39ypz8vhqfzjnqhibvryshnxdfcsfy2jjyn0j7x0yi74g"))))
(properties `((upstream-name . "RcppArmadillo")))
(build-system r-build-system)
(propagated-inputs
@@ -2857,18 +2859,19 @@ certain criterion, e.g., it contains a certain regular file.")
(define-public r-rmarkdown
(package
(name "r-rmarkdown")
- (version "2.20")
+ (version "2.21")
(source
(origin
(method url-fetch)
(uri (cran-uri "rmarkdown" version))
(sha256
- (base32 "178mc3dqm11y58k8jdhm1yi11bbl1h7bls9d8f94ngmlzjdhbxyp"))))
+ (base32 "0a5czn18clfnw0a9nd5v98ah4h47i32423s6jdf126ni4aj20ny2"))))
(properties `((upstream-name . "rmarkdown")))
(build-system r-build-system)
(propagated-inputs
(list r-bslib
r-evaluate
+ r-fontawesome
r-htmltools
r-jquerylib
r-jsonlite
@@ -2890,13 +2893,13 @@ variety of formats.")
(define-public r-gtable
(package
(name "r-gtable")
- (version "0.3.2")
+ (version "0.3.3")
(source (origin
(method url-fetch)
(uri (cran-uri "gtable" version))
(sha256
(base32
- "1j162vkyvkyyz61smw36crgmd76jic17n9qfmn0cyvafzdyqyiwd"))))
+ "0fkv19h64cyxsadplvyzbpjliy9wlfg56hc8znvqg972g3cmi6ig"))))
(properties `((upstream-name . "gtable")))
(build-system r-build-system)
(propagated-inputs
@@ -2979,13 +2982,13 @@ a column in data frame.")
(define-public r-rsqlite
(package
(name "r-rsqlite")
- (version "2.3.0")
+ (version "2.3.1")
(source (origin
(method url-fetch)
(uri (cran-uri "RSQLite" version))
(sha256
(base32
- "0csx2zz4zlr11nrzcas1lzhzjb4ygv6nijg2jpkp5l4fs2hijbj4"))))
+ "1jil3wgfh1asfb9c4cr9qyr74wb9f87r7sa03kj187201hb3xlly"))))
(properties `((upstream-name . "RSQLite")))
(build-system r-build-system)
(propagated-inputs
@@ -3009,13 +3012,13 @@ engine (version 3.8.8.2) is included.")
(define-public r-rcurl
(package
(name "r-rcurl")
- (version "1.98-1.10")
+ (version "1.98-1.12")
(source (origin
(method url-fetch)
(uri (cran-uri "RCurl" version))
(sha256
(base32
- "1m7i0q9scrh2bfr0nqs029052kznhlv3siz9055pzdvgig7jnqjs"))))
+ "1ci6lsxm0f13yzw712gcbq23syl54x5llvhs2w1b8wwm9vqgx0qs"))))
(properties `((upstream-name . "RCurl")))
(build-system r-build-system)
(arguments
@@ -3032,7 +3035,7 @@ if (certs != \"\") { .opts = merge.list(.opts, list(cainfo=certs)) }
(native-inputs
(list libxml2))
(inputs
- (list curl zlib))
+ (list curl))
(propagated-inputs
(list r-bitops))
(home-page "https://www.omegahat.net/RCurl")
@@ -3172,14 +3175,14 @@ statements.")
(define-public r-segmented
(package
(name "r-segmented")
- (version "1.6-2")
+ (version "1.6-3")
(source
(origin
(method url-fetch)
(uri (cran-uri "segmented" version))
(sha256
(base32
- "0livckkhci3w1x9xai2m0a30fj06qsks2qds7y5jr9vwx03jqg21"))))
+ "0x7k5ycbvnfqsygrcyaaxnl0060x6869b345xc697hhr9sfxb4ai"))))
(build-system r-build-system)
(propagated-inputs (list r-mass r-nlme))
(home-page "https://cran.r-project.org/web/packages/segmented")
@@ -3801,13 +3804,13 @@ analysis of large sparse or dense matrices.")
(define-public r-glmnet
(package
(name "r-glmnet")
- (version "4.1-6")
+ (version "4.1-7")
(source
(origin
(method url-fetch)
(uri (cran-uri "glmnet" version))
(sha256
- (base32 "0c3y9g3k0f0yclcffxzgfhfylb3py0iydhyspcjdrl44lb7cdi5y"))))
+ (base32 "1a7af2658z9fmx0rcdx401lj86q73qkvsvlfnrp2bw4xv43bd85k"))))
(build-system r-build-system)
(native-inputs
(list gfortran r-knitr))
@@ -4307,14 +4310,14 @@ and tidyr provides no margins or aggregation.")
(define-public r-hexbin
(package
(name "r-hexbin")
- (version "1.28.2")
+ (version "1.28.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "hexbin" version))
(sha256
(base32
- "0bbhs5pwxh474w62sq6gqvih7habancxng9wd4f2rgn6lv9zhhb2"))))
+ "0pyy97bh9xf9hijg3iw1z4ri01571r1fx7xqm3fjkzx4q48kbcqf"))))
(build-system r-build-system)
(propagated-inputs
(list r-lattice))
@@ -5392,14 +5395,14 @@ can be efficiently implemented directly in the R language.")
(define-public r-robustbase
(package
(name "r-robustbase")
- (version "0.95-0")
+ (version "0.95-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "robustbase" version))
(sha256
(base32
- "094pxwp78bmqyn6vncyzrazqxnn8abqsbzhlcq44avfz8qffmyjw"))))
+ "1sm37gqs35cvkacigsla8kzvpzjzsrgkabf58ymk9pzcndnx4b46"))))
(build-system r-build-system)
(native-inputs
(list gfortran))
@@ -5840,13 +5843,13 @@ Companion to Applied Regression, Third Edition, Sage.")
(define-public r-car
(package
(name "r-car")
- (version "3.1-1")
+ (version "3.1-2")
(source
(origin
(method url-fetch)
(uri (cran-uri "car" version))
(sha256
- (base32 "1g6jdcxl2aig6zirdn3k5l48sjmpljzy1aadnlr6mr6pxqamiicg"))))
+ (base32 "1j3l8r3j05769gdfrqz0n38xviq6pww1cjrgdd0fkj3sjy8k89l9"))))
(build-system r-build-system)
(propagated-inputs
(list r-abind
@@ -5964,17 +5967,18 @@ first and second order derivatives.")
(define-public r-sn
(package
(name "r-sn")
- (version "2.1.0")
+ (version "2.1.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "sn" version))
(sha256
(base32
- "12s4g9rfrnijdil7bqw66ikj5k3w6bdnz6fsgqsp0bkfsap9nps9"))))
+ "1g92vwbg0kqnqpsgianid2r91334p5shi39hr26v2z6wj5nvbxpr"))))
(build-system r-build-system)
(propagated-inputs
(list r-mnormt r-numderiv r-quantreg))
+ (native-inputs (list r-r-rsp))
(home-page "http://azzalini.stat.unipd.it/SN")
(synopsis "The skew-normal and skew-t distributions")
(description
@@ -5988,14 +5992,14 @@ multivariate case.")
(define-public r-tclust
(package
(name "r-tclust")
- (version "1.5-2")
+ (version "1.5-4")
(source
(origin
(method url-fetch)
(uri (cran-uri "tclust" version))
(sha256
(base32
- "12vg9q35srddjidrn3q955xybn6ldraya35s4955ypj61arp89j9"))))
+ "1a3i6kvfzc2d6rdf75w03n5172jihhqa8mvzcb4m8l0w6mgdlm9b"))))
(build-system r-build-system)
;; These are all suggested packages, not build dependencies.
(propagated-inputs
@@ -6011,14 +6015,14 @@ diagnostic tools (@code{ctlcurves} and @code{DiscrFact}).")
(define-public r-ranger
(package
(name "r-ranger")
- (version "0.14.1")
+ (version "0.15.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "ranger" version))
(sha256
(base32
- "06zf5mi6yfgb68m6m83k01r4ikj5nldrvrbh3jqwz8axalfl16ax"))))
+ "0bibv9xf6w8k8nsc13f2yd4kx99aq0i758h3wfh089szgkpdjrad"))))
(build-system r-build-system)
(propagated-inputs
(list r-rcpp r-matrix r-rcppeigen))
@@ -7356,16 +7360,16 @@ Neyman, 1936; cf. Spiller et al., 2012), etc.")
(define-public r-mumin
(package
(name "r-mumin")
- (version "1.47.1")
+ (version "1.47.5")
(source (origin
(method url-fetch)
(uri (cran-uri "MuMIn" version))
(sha256
(base32
- "1xhsc9hmx2b3zqyvpjs64rs90ccrfcsglrq2mhh85mgplsnva8qj"))))
+ "0xqasb79lmdhff25zalzrpjwv6qs9qnxr54ypnqjjgshi96mbwvg"))))
(properties `((upstream-name . "MuMIn")))
(build-system r-build-system)
- (propagated-inputs (list r-matrix r-nlme))
+ (propagated-inputs (list r-insight r-matrix r-nlme))
(home-page "https://cran.r-project.org/package=MuMIn")
(synopsis "Multi-Model Inference")
(description
@@ -7375,3 +7379,40 @@ model inclusion. Model parameter and prediction averaging based on model
weights derived from information criteria (AICc and alike) or custom model
weighting schemes.")
(license license:gpl2)))
+
+(define-public ruby-enumerable-statistics
+ (package
+ (name "ruby-enumerable-statistics")
+ (version "2.0.7")
+ ;; Source at RubyGems.org doesn't have tests.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrkn/enumerable-statistics.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1a8k2dvm1v0g6hcrbnzy0f7d63hdmpmldfdkl8wr32nbl05xnifa"))
+ (modules '((guix build utils)))
+ (snippet `(begin
+ (substitute* "enumerable-statistics.gemspec"
+ ;; benchmark-driver gem is used for
+ ;; performance benchmarking, and isn't
+ ;; needed for tests.
+ (("spec.add_development_dependency \"benchmark-driver\"\n")
+ ""))))))
+ (build-system ruby-build-system)
+ (native-inputs (list bundler
+ ruby-rake
+ ruby-rake-compiler
+ ruby-rspec
+ ruby-test-unit
+ ruby-fuubar
+ ruby-yard))
+ (synopsis "Library which provides statistics features for Enumerable")
+ (description
+ "@code{Enumerable::Statistics} provides some methods to calculate
+statistical summary in arrays and enumerables.")
+ (home-page "https://github.com/mrkn/enumerable-statistics")
+ (license license:expat)))