aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm21
1 files changed, 4 insertions, 17 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 5ea5148cbc..5c954eae35 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -116,23 +116,10 @@ applications.")
(propagated-inputs `(("libgcrypt" ,libgcrypt)
("zlib" ,zlib)))
(arguments `(#:configure-flags `("--with-libgcrypt")
- #:phases
- ;; FIXME: In the next core-updates cycle, replace the entire
- ;; following ,(...) form with its first 'modify-phases'
- ;; subform. The change made here is only strictly needed on
- ;; MIPS, but should work on any system. For now, we apply it
- ;; only to MIPS to avoid forcing thousands of rebuilds on
- ;; other systems.
- ,(if (string-prefix? "mips" (or (%current-target-system)
- (%current-system)))
- '(modify-phases %standard-phases
- (replace 'bootstrap
- (lambda _
- (invoke "autoreconf" "-v"))))
- '(modify-phases %standard-phases
- (add-before 'configure 'autoreconf
- (lambda _
- (invoke "autoreconf" "-v")))))))
+ #:phases (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "autoreconf" "-v"))))))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)))
(synopsis "Client-side C library implementing the SSH2 protocol")