aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm34
1 files changed, 23 insertions, 11 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 3064e385e2..2df0ce1364 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -99,7 +99,6 @@ arbitrary data types and reversibly turns them into different representations,
such as compact binary encodings, XML, or JSON.")
(license license:bsd-3)))
-
(define-public msgpack
(package
(name "msgpack")
@@ -132,13 +131,6 @@ such as compact binary encodings, XML, or JSON.")
;; zbuffer.hpp) which #include <zlib.h>. However, 'guix gc --references'
;; does not detect a store reference to zlib since these headers are not
;; compiled.
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'autoconf
- (lambda _
- (invoke "autoreconf" "-vfi")
- #t)))))
(home-page "https://www.msgpack.org")
(synopsis "Binary serialization library")
(description "Msgpack is a library for C/C++ that implements binary
@@ -225,6 +217,26 @@ that implements both the msgpack and msgpack-rpc specifications.")
(home-page "https://github.com/libmpack/libmpack-lua")
(synopsis "Lua bindings for the libmpack binary serialization library")))
+(define-public lua5.1-libmpack
+ (package (inherit lua-libmpack)
+ (name "lua5.1-libmpack")
+ (arguments
+ (substitute-keyword-arguments (package-arguments lua-libmpack)
+ ((#:make-flags flags)
+ `(let* ((lua-version ,(package-version lua-5.1))
+ (lua-major+minor ,(version-major+minor (package-version lua-5.1))))
+ (list "CC=gcc"
+ "USE_SYSTEM_LUA=yes"
+ (string-append "MPACK_LUA_VERSION=" lua-version)
+ (string-append "MPACK_LUA_VERSION_NOPATCH=" lua-major+minor)
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out"))
+ (string-append "LUA_CMOD_INSTALLDIR="
+ (assoc-ref %outputs "out")
+ "/lib/lua/" lua-major+minor))))))
+ (inputs
+ `(("lua" ,lua-5.1)))))
+
(define-public lua5.2-libmpack
(package (inherit lua-libmpack)
(name "lua5.2-libmpack")
@@ -418,7 +430,7 @@ to generate and parse. The two primary functions are @code{cbor.loads} and
(define-public flatbuffers
(package
(name "flatbuffers")
- (version "1.9.0")
+ (version "1.10.0")
(source
(origin
(method url-fetch)
@@ -426,7 +438,7 @@ to generate and parse. The two primary functions are @code{cbor.loads} and
version ".tar.gz"))
(sha256
(base32
- "1qs7sa9q4q6hs12yp875lvrv6393178qcmqs1ziwmjk088g4k9aw"))))
+ "0z4swldxs0s31hnkqdhsbfmc8vx3p7zsvmqaw4l31r2iikdy651p"))))
(build-system cmake-build-system)
(arguments
'(#:build-type "Release"
@@ -435,7 +447,7 @@ to generate and parse. The two primary functions are @code{cbor.loads} and
(assoc-ref %outputs "out") "/lib"))))
(home-page "https://google.github.io/flatbuffers/")
(synopsis "Memory-efficient serialization library")
- (description "FlatBuffers is a cross platform serialization library for C++,
+ (description "FlatBuffers is a cross-platform serialization library for C++,
C#, C, Go, Java, JavaScript, PHP, and Python. It was originally created for
game development and other performance-critical applications.")
(license license:asl2.0)))