aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm33
1 files changed, 4 insertions, 29 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index b85c507d64..489c53f41d 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Corentin Bocquillon <corentin@nybble.fr>
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
@@ -34,20 +34,17 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
- #:use-module (guix build-system r)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
- #:use-module (gnu packages cran)
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
#:use-module (gnu packages lua)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages statistics))
+ #:use-module (gnu packages perl))
(define-public cereal
(package
@@ -402,14 +399,14 @@ However, “Memory efficiency” and “Speed” have not been primary goals.")
(define-public python-ruamel.yaml
(package
(name "python-ruamel.yaml")
- (version "0.15.37")
+ (version "0.15.83")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ruamel.yaml" version))
(sha256
(base32
- "0629xzlwbddfwp8lkjz3mpvxhml9kx17cfs8aydzg55idzcl562h"))))
+ "0p4i8ad28cbbbjja8b9274irkhnphhvhap3aym6yb8xfp1d72kpw"))))
(build-system python-build-system)
(native-inputs
`(("python-pytest" ,python-pytest)))
@@ -477,28 +474,6 @@ C#, C, Go, Java, JavaScript, PHP, and Python. It was originally created for
game development and other performance-critical applications.")
(license license:asl2.0)))
-(define-public r-feather
- (package
- (name "r-feather")
- (version "0.3.1")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "feather" version))
- (sha256
- (base32
- "1q6dbkfnkpnabq8lb6bm9ma44cfcghx2lm23pyk3vg7943wrn1pi"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-hms" ,r-hms)
- ("r-rcpp" ,r-rcpp)
- ("r-tibble" ,r-tibble)))
- (home-page "https://github.com/wesm/feather")
- (synopsis "R Bindings to the Feather API")
- (description "Read and write feather files, a lightweight binary columnar
-daa store designed for maximum speed.")
- (license license:asl2.0)))
-
(define-public python-feather-format
(package
(name "python-feather-format")