aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1437054d78..4b12ada5d4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7567,3 +7567,21 @@ https://github.com/flavorjones/loofah-activerecord).")
"The Listen gem listens to file modifications and notifies you about the changes. Works everywhere!")
(home-page "https://github.com/guard/listen")
(license license:expat)))
+
+(define-public ruby-listen-3.0
+ (package
+ (inherit ruby-listen)
+ (name "ruby-listen")
+ (version "3.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The gem does not include a Rakefile, so we fetch the tarball from
+ ;; Github.
+ (uri (string-append "https://github.com/guard/listen/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06cy038xlbi8hcr9nv0c9wvafi7s3d05sdc7ydkv8qndi9bs68l3"))
+ (patches (search-patches "ruby-listen-3.0.8-patch-gemspec.patch"))))))