aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 30 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4c16f84099..5a89288166 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Holgr Peters <holger.peters@posteo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6344,14 +6345,14 @@ alternative to Marshal for Object serialization. ")
(define-public ruby-pg
(package
(name "ruby-pg")
- (version "1.1.4")
+ (version "1.2.3")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "pg" version))
(sha256
(base32
- "0fmnyxcyrvgdbgq7m09whgn9i8rwfybk0w8aii1nc4g5kqw0k2jy"))))
+ "13mfrysrdrh8cka1d96zm0lnfs59i5x2g6ps49r2kz5p3q81xrzj"))))
(build-system ruby-build-system)
(arguments
'(#:test-target "spec"))
@@ -11716,3 +11717,30 @@ which snapshots to consider and what files to include.")
defined in @file{.travis.yml} on your local machine, using @code{rvm},
@code{rbenv}, or @code{chruby} to test different versions of Ruby.")
(license license:expat)))
+
+(define-public ruby-rugged
+ (package
+ (name "ruby-rugged")
+ (version "1.1.0")
+ (home-page "https://www.rubydoc.info/gems/rugged")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rugged" version))
+ (sha256
+ (base32 "04aq913plcxjw71l5r62qgz3bx3466p0wvgyfqahg5n3nybmcwqy"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f
+ #:gem-flags (list "--" "--use-system-libraries")))
+ (inputs
+ `(("libgit2" ,libgit2)))
+ (native-inputs
+ `(("ruby-minitest" ,ruby-minitest)
+ ("ruby-pry" ,ruby-pry)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis "Ruby bindings to the libgit2 linkable C Git library")
+ (description "Rugged is a library for accessing libgit2 in Ruby. It gives
+you the speed and portability of libgit2 with the beauty of the Ruby
+language.")
+ (license license:expat)))